dev-python/characteristic: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:40:56 +0000 (13:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:59:27 +0000 (13:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/characteristic/characteristic-14.3.0-r1.ebuild [deleted file]
dev-python/characteristic/characteristic-14.3.0-r2.ebuild [deleted file]

diff --git a/dev-python/characteristic/characteristic-14.3.0-r1.ebuild b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
deleted file mode 100644 (file)
index d0444bb..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python attributes without the boilerplate"
-HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       # Prevent un-needed download during build
-       sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/characteristic/characteristic-14.3.0-r2.ebuild b/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
deleted file mode 100644 (file)
index 0583900..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python attributes without the boilerplate"
-HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       # Prevent un-needed download during build
-       sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}