app-emulation/ganeti-instance-image: Revbump to 0.6-r2 (bug #687974)
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 14 Jun 2019 20:12:33 +0000 (13:12 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 14 Jun 2019 20:12:33 +0000 (13:12 -0700)
Drop patch that was added in 0.6-r1.

Closes: https://bugs.gentoo.org/687974
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild [new file with mode: 0644]

diff --git a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild
new file mode 100644 (file)
index 0000000..9e62e96
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]]; then
+       EGIT_REPO_URI="git://git.osuosl.org/${PN}.git"
+       EGIT_BRANCH="master"
+       inherit git-r3 autotools
+else
+       SRC_URI="http://ftp.osuosl.org/pub/osl/ganeti-instance-image/${P}.tar.gz"
+fi
+
+DESCRIPTION="Scripts to build out CD or image based VMs using Ganeti"
+HOMEPAGE="http://code.osuosl.org/projects/ganeti-image"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dump
+       >=app-emulation/ganeti-2.15.2-r7
+       app-emulation/qemu
+       sys-apps/util-linux
+       sys-fs/multipath-tools
+       sys-fs/e2fsprogs"
+
+src_prepare() {
+       default
+       if [[ ${PV} == "9999" ]]; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       econf --with-default-dir=/etc/ganeti
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "install failed"
+
+       rm -rf "${D}"/usr/share/doc/${PN}
+       dodoc README.markdown NEWS ChangeLog
+       insinto /etc/ganeti
+       newins defaults ${PN}
+}