net-p2p/xmr-stak-rx: 1.0.4 version bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 29 Dec 2019 19:43:31 +0000 (14:43 -0500)
committerCraig Andrews <candrews@gentoo.org>
Sun, 29 Dec 2019 19:46:22 +0000 (14:46 -0500)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-p2p/xmr-stak-rx/Manifest
net-p2p/xmr-stak-rx/xmr-stak-rx-1.0.4.ebuild [new file with mode: 0644]

index 8de32cc61a1d426aca0bcf69be383b7531a33b00..acb9267b73dcac7c8c93bd6fdbdd598a5ab63c1f 100644 (file)
@@ -1,3 +1,4 @@
 DIST xmr-stak-rx-1.0.1.tar.gz 500735 BLAKE2B 112b75122f35358c8558dec116a5f37bbbd13e9f57a767e03e85da37ab4a408831aa50bf5f2415451f776492b42c5a4a36de730fefc7d99bb13f437c9007d549 SHA512 488884948ad66445c37725397152201883feef8aff5afecaa93297a5bb45e65173b095e2e796d729bd8e9c778e94ee6fb65146250be54c39b10635a2569b6866
 DIST xmr-stak-rx-1.0.2.tar.gz 2590320 BLAKE2B e4bd4770ebd491182633a544a89e9ece25e471dfded7592680e0685883a805b26a0266982c0474f8a0db2c0ecf40412e4976c3ca7a4dc9f5f91f59bab947d277 SHA512 5a31ae5ae6e27c6bd2300c5e5056de733037d149fa7656b91da37f4e9dfb4f1cd1986503c30b84c4a5ee2539c12992dd5e5e883fb808d435d50484290cdb7e87
 DIST xmr-stak-rx-1.0.3.tar.gz 2590745 BLAKE2B 4b7d452728f9a18239a91de08fe3bda8e515fd96d47e3411b83d77ec254fac70d1ac9f334fffb6eb09bd57a4f7c533b214ad017a207190e5800ff27cdcccc6a4 SHA512 0836cde0766f781462957c196683b343ea48c10afee184db324ca6b62c4c7b53e381e8e4f4e41690148ae903b074d0cf0d51fed6a411b6bdaccb6f383e802935
+DIST xmr-stak-rx-1.0.4.tar.gz 2595481 BLAKE2B acd0667301255ba145d42ea6a3f6acf731ca9946beccacd6db973a25a03c0e9f53dacb0e716f739f17f38e42b3ccb25e5af9052b7884ccfa0d5e89b6a3ab3c85 SHA512 ce2fb84e88cd3fe2d75d73c6027eea0823d3ac77463229ae838b97ba0e91d43d5f30365363049f7de7a7c1e8e85b5511850da86ecb07ae3db86d276241a7cce3
diff --git a/net-p2p/xmr-stak-rx/xmr-stak-rx-1.0.4.ebuild b/net-p2p/xmr-stak-rx/xmr-stak-rx-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..5bd1342
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/fireice-uk/xmr-stak.git"
+       EGIT_BRANCH="xmr-stak-rx-dev"
+       inherit git-r3
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/fireice-uk/xmr-stak/archive/${PV}-rx.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/xmr-stak-${PV}-rx"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Monero RandomX Miner"
+HOMEPAGE="https://github.com/fireice-uk/xmr-stak"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cuda hwloc opencl ssl webserver"
+
+DEPEND="cuda? ( dev-util/nvidia-cuda-toolkit )
+       hwloc? ( sys-apps/hwloc )
+       opencl? ( virtual/opencl )
+       ssl? ( dev-libs/openssl:0= )
+       webserver? ( net-libs/libmicrohttpd )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCUDA_ENABLE=$(usex cuda)
+               -DHWLOC_ENABLE=$(usex hwloc)
+               -DMICROHTTPD_ENABLE=$(usex webserver)
+               -DOpenCL_ENABLE=$(usex opencl)
+               -DOpenSSL_ENABLE=$(usex ssl)
+               -DLIBRARY_OUTPUT_PATH=$(get_libdir)
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+       doinitd "${FILESDIR}"/${PN}
+       dodir /etc/xmr-stak-rx
+}
+
+pkg_postinst() {
+       if [ ! -e "${ROOT}/etc/xmr-stak-rx/main.config" ]; then
+               ewarn "To use xmr-stack-rx:"
+               if use cuda || use opencl; then
+                       ewarn "As root or as a user that is a member of the 'video' group,"
+               fi
+               ewarn "run:"
+               ewarn "/usr/bin/xmr-stak-rx --cpu /etc/xmr-stak-rx/cpu.config --amd /etc/xmr-stak-rx/amd.config --nvidia /etc/xmr-stak-rx/nvidia.config -c /etc/xmr-stak-rx/main.config -C /etc/xmr-stak-rx/pools.txt"
+               ewarn "xmr-stak-rx can now be terminated and 'systemctl start xmr-stak-rx' or '/etc/init.d/xmr-stak-rx start' can be used."
+       fi
+}