sys-libs/libunwind: unkeyword riscv
authorGöktürk Yüksek <gokturk@gentoo.org>
Thu, 10 Oct 2019 20:07:33 +0000 (16:07 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Thu, 10 Oct 2019 20:48:32 +0000 (16:48 -0400)
There doesn't seem to be any official support for RISC-V yet. The
build fails with:

  checking for ELF helper width... configure: error: Unknown ELF target: riscv64

The git HEAD (commit a36ec8cfdb8764e4f8bf6b16a149a60ea6ad038d) doesn't
seem to provide support for RISC-V either:

AC_MSG_CHECKING([for ELF helper width])
case "${target_arch}" in
(arm|hppa|ppc32|x86|sh) use_elf32=yes; AC_MSG_RESULT([32]);;
(aarch64|ia64|ppc64|x86_64|s390x|tilegx)  use_elf64=yes; AC_MSG_RESULT([64]);;
(mips)                 use_elfxx=yes; AC_MSG_RESULT([xx]);;
*)                     AC_MSG_ERROR([Unknown ELF target: ${target_arch}])
esac

This reverts commit 9037f242c1d5941a57612f6b617cc74b761e6896.

Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
profiles/arch/riscv/package.use.mask
sys-libs/libunwind/libunwind-1.2.1-r3.ebuild

index 0a6c2f0e282548554f2d34510a9d5a9777b88bb3..a16d07ecc3470728fc55d1b02b0177016412713e 100644 (file)
@@ -49,6 +49,7 @@ dev-util/meson test
 dev-util/ninja doc test
 dev-util/patchutils test
 dev-util/pkgconf test
+dev-util/strace unwind
 dev-vcs/git cvs highlight gnome-keyring subversion tk xinetd
 media-libs/freetype harfbuzz png
 media-libs/tiff jbig jpeg test webp zstd
index 518da3a72e5dc4eb01102ed4a3807fc31ace681a..27084d43a5b96a949e962c2a6dc1d669ef2fee4a 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="7"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
 IUSE="debug debug-frame doc libatomic lzma +static-libs"
 
 RESTRICT="test" # half of tests are broken (toolchain version dependent)