sys-boot/unetbootin: Set and use path to Qt4 executables (maybe bug #557142).
authorJeroen Roovers <jer@gentoo.org>
Sun, 16 Aug 2015 07:39:25 +0000 (09:39 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 16 Aug 2015 07:39:25 +0000 (09:39 +0200)
Package-Manager: portage-2.2.20.1

sys-boot/unetbootin/unetbootin-619.ebuild

index 9fb9454c24ca12d04d7162f037e4f790c0f47b14..8a9b6047390728cabf4a943a38c3485a9e3a2eee 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit eutils qt4-r2
+inherit eutils qmake-utils qt4-r2
 
 DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
 HOMEPAGE="https://github.com/unetbootin/unetbootin"
@@ -62,8 +62,11 @@ src_prepare() {
 
 src_configure() {
        sed -i -e '/^RESOURCES/d' unetbootin.pro || die
-       lupdate ${PN}.pro || die
-       lrelease ${PN}.pro || die
+
+       UNBN_QTPATH="$(qt4_get_bindir)/"
+       ${UNBN_QTPATH}lupdate ${PN}.pro || die
+       ${UNBN_QTPATH}lrelease ${PN}.pro || die
+
        eqmake4 ${PN}.pro || die
 }