media-gfx/eog-plugins: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 4 Oct 2015 10:28:17 +0000 (12:28 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 4 Oct 2015 10:28:17 +0000 (12:28 +0200)
Package-Manager: portage-2.2.22

media-gfx/eog-plugins/Manifest
media-gfx/eog-plugins/eog-plugins-3.16.2.ebuild [new file with mode: 0644]

index 15060246da875b61e989bb8996767a707fbf3632..781c18c32f44f9caedaeb19e183b886d20fe1ea3 100644 (file)
@@ -1,3 +1,4 @@
 DIST eog-plugins-3.14.2.tar.xz 363836 SHA256 31a33b65cd6452ebeca3821f6eb45caefb83bd5d121dee7cf7e4c139ba065f89 SHA512 b29e0aa247ce7006a339ba4a4352e9dfe0150662f2a40fbdb10ac21daca95bb8c75b921cfad4a57ee783424befd98145a35f2a9b8a0083a9bff3928c157fa058 WHIRLPOOL ecc6d4e3a60b7e00f5bbb955040c2f43eb7e1d309970b2084bd50ac706fe149df50ae8e7ab7d595caca0b4853113bfb7073c5e785560b999c5b7db86bc277746
 DIST eog-plugins-3.16.0.tar.xz 367436 SHA256 6fab1c1e0705fc2b0e4a63caf3ba1c5b64b4eaa1301e4cbc04bb934428b68450 SHA512 f592aa08754a1f2d5f503239b5b68b4d9617aa0a1e5a0afd3b80d5bc11fcd312b219157607ff53d98927b9b63e088009c5bb5181dbbcc71466785780b3339fe9 WHIRLPOOL 564a3cf6f572a50fad2f9772138afb80d6ca5a3b3b5c178183d36a95f7fea23d7bd499751a27a40e449dd340e3fc626e8a0c64b3d7c056e3abec9ff62ae78727
 DIST eog-plugins-3.16.1.tar.xz 368652 SHA256 c586b6708064dcd03612f9373a6160214b2fa4797bf8c07db530b18eda4074d9 SHA512 f7871cd99e54f65796c659d69bb1f741a706c243c2f0683c6efe38ae685a1a5b66a31a1dcb2bcea84a516b385a16c4d871ad78ebfa043dc8f895729d07758429 WHIRLPOOL 2a564c7e53eaf6daf283daa34845021eac3dbb30625dc307d749aab3a92f7e9cebed168af1d7d7f23bdeaa53ada957b448341fa97708ea57e5005dd024e4614c
+DIST eog-plugins-3.16.2.tar.xz 369252 SHA256 f33de3c78d6a7d8a89441daa9c3e49e043dcdc527b0b7d477f0bf2d3af08e534 SHA512 4791946a86880844b87a1e6dd0fe7755e1e4dc2558d18e3df2e9410a355224de9787efb0cea9fc8c843ec9c11a907f90d5902fddc093f1af671c9cee20d45fe5 WHIRLPOOL 3252ab0dadf2fb0bc7b161cf56018f51136dd2195aef2f2755218f9d614f7b13766c5002981d1562ec5d383afb9a125afa2a464569d2289cb996d26119e57c63
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.2.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.2.ebuild
new file mode 100644 (file)
index 0000000..5d2c656
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+       map? ( exif )
+       python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+       >=dev-libs/glib-2.38:2
+       >=dev-libs/libpeas-0.7.4:=
+       >=media-gfx/eog-3.15.90
+       >=x11-libs/gtk+-3.14:3
+       exif? ( >=media-libs/libexif-0.6.16 )
+       flickr? ( media-gfx/postr )
+       map? (
+               media-libs/libchamplain:0.12[gtk]
+               >=media-libs/clutter-1.9.4:1.0
+               >=media-libs/clutter-gtk-1.1.2:1.0 )
+       picasa? ( >=dev-libs/libgdata-0.9.1:= )
+       python? (
+               ${PYTHON_DEPS}
+               >=dev-libs/glib-2.32:2[dbus]
+               dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_USEDEP}]
+               gnome-base/gsettings-desktop-schemas
+               media-gfx/eog[introspection]
+               x11-libs/gtk+:3[introspection]
+               x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/intltool-0.50.1
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+pkg_setup() {
+       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_configure() {
+       local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+       use exif && plugins="${plugins},exif-display"
+       use flickr && plugins="${plugins},postr"
+       use map && plugins="${plugins},map"
+       use picasa && plugins="${plugins},postasa"
+       use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+       gnome2_src_configure \
+               $(use_enable python) \
+               --with-plugins=${plugins}
+}