dev-ros/camera_calibration_parsers: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 09:19:38 +0000 (11:19 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 09:44:13 +0000 (11:44 +0200)
Package-Manager: portage-2.2.21

dev-ros/camera_calibration_parsers/Manifest [new file with mode: 0644]
dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.7.ebuild [new file with mode: 0644]
dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild [new file with mode: 0644]
dev-ros/camera_calibration_parsers/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/camera_calibration_parsers/Manifest b/dev-ros/camera_calibration_parsers/Manifest
new file mode 100644 (file)
index 0000000..a917fac
--- /dev/null
@@ -0,0 +1 @@
+DIST image_common-1.11.7.tar.gz 49437 SHA256 1a739aef8ea597f6e7eaad26c031ad90e797efcb9cae764cd352bb124e9744ca SHA512 7408b641c75b6227130218862674609521d8465680ac15d45fc296de6ad3372ef1dde225a812740e0d5200f5923b52b4e9c2fca4dd4f96104f0bfe901400f456 WHIRLPOOL 1c8aee3e738ced0d4b45695a7dd10b1140a330abd8b121c91e2816bed329fc23a1ae39b8150fc81f81b9b586d3a747a9e4d6541914f1caabf6df06cf7cf57441
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.7.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.7.ebuild
new file mode 100644 (file)
index 0000000..e9cd4e2
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/boost:=
+       dev-ros/rosconsole
+       >=dev-cpp/yaml-cpp-0.5
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( dev-python/nose )
+"
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
new file mode 100644 (file)
index 0000000..e9cd4e2
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/boost:=
+       dev-ros/rosconsole
+       >=dev-cpp/yaml-cpp-0.5
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( dev-python/nose )
+"
diff --git a/dev-ros/camera_calibration_parsers/metadata.xml b/dev-ros/camera_calibration_parsers/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>