dev-util/kbuild: Don't build with distcc
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 20 Apr 2019 13:51:09 +0000 (15:51 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 20 Apr 2019 13:51:09 +0000 (15:51 +0200)
Closes: https://bugs.gentoo.org/255371
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-util/kbuild/kbuild-0.1.9998.3149.ebuild
dev-util/kbuild/kbuild-9999.ebuild

index 7c358202b8854e6d3759b3ef13af36bc9e1ccb6a..4ed9922800e38339e8c67eefb0e287f2be5f5384 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,6 +32,11 @@ PATCHES=(
        "${FILESDIR}/${PN}-0.1.9998_pre20171020-gold.patch"
 )
 
+pkg_setup() {
+       # Package fails with distcc (bug #255371)
+       export DISTCC_DISABLE=1
+}
+
 src_prepare() {
        rm -rf "${S}/kBuild/bin"
 
index ccbf4507612e1dfdef8b2c5e1319c83407e9cc90..ac794242d86c6822cffccc26ab1f86ea47a2cbf0 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -20,6 +20,11 @@ RDEPEND=""
 
 S="${WORKDIR}/${MY_P/-src}"
 
+pkg_setup() {
+       # Package fails with distcc (bug #255371)
+       export DISTCC_DISABLE=1
+}
+
 src_prepare() {
        default
        rm -rf "${S}/kBuild/bin" || die