media-video/ffmpeg: Check for -mcpu, then -march and finally -mtune for determining...
authorAlexis Ballier <aballier@gentoo.org>
Sat, 22 Aug 2015 09:53:37 +0000 (11:53 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 22 Aug 2015 09:53:37 +0000 (11:53 +0200)
Should fix https://bugs.gentoo.org/show_bug.cgi?id=553632

Package-Manager: portage-2.2.20.1

media-video/ffmpeg/ffmpeg-2.6.3.ebuild
media-video/ffmpeg/ffmpeg-2.6.4.ebuild
media-video/ffmpeg/ffmpeg-2.7.2.ebuild
media-video/ffmpeg/ffmpeg-9999.ebuild

index fb7c820039ef4c98389b81585bdae8f0362d1d4d..2f513ba70b81b118af55790515c6021000cf20e7 100644 (file)
@@ -364,7 +364,7 @@ multilib_src_configure() {
        # We need to do this so that features of that CPU will be better used
        # If they contain an unknown CPU it will not hurt since ffmpeg's configure
        # will just ignore it.
-       for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+       for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
                [[ ${i} = native ]] && i="host" # bug #273421
                myconf+=( --cpu=${i} )
                break
index c970d54625f9e2c191cd351b356276c5055c0423..f4e269cfb2ffefe53ad95d11bfc1f3e44bcad086 100644 (file)
@@ -364,7 +364,7 @@ multilib_src_configure() {
        # We need to do this so that features of that CPU will be better used
        # If they contain an unknown CPU it will not hurt since ffmpeg's configure
        # will just ignore it.
-       for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+       for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
                [[ ${i} = native ]] && i="host" # bug #273421
                myconf+=( --cpu=${i} )
                break
index 280e101cd3681fb86ead70ad23d080d281d2f23f..c568a8f7a547b6017254ec89cb41dfd6f9ad8404 100644 (file)
@@ -364,7 +364,7 @@ multilib_src_configure() {
        # We need to do this so that features of that CPU will be better used
        # If they contain an unknown CPU it will not hurt since ffmpeg's configure
        # will just ignore it.
-       for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+       for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
                [[ ${i} = native ]] && i="host" # bug #273421
                myconf+=( --cpu=${i} )
                break
index ca8ee9ff8c251acf80e150bc0c52e210e91e452d..fa8dea8b74c5e1384bd5f16014422d94f5931878 100644 (file)
@@ -366,7 +366,7 @@ multilib_src_configure() {
        # We need to do this so that features of that CPU will be better used
        # If they contain an unknown CPU it will not hurt since ffmpeg's configure
        # will just ignore it.
-       for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+       for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
                [[ ${i} = native ]] && i="host" # bug #273421
                myconf+=( --cpu=${i} )
                break