sci-libs/shapelib: Add missing RDEPEND
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 23 Jan 2017 11:06:06 +0000 (12:06 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 23 Jan 2017 11:06:06 +0000 (12:06 +0100)
Gentoo-bug: 606884

Package-Manager: portage-2.3.0

sci-libs/shapelib/shapelib-1.4.0-r1.ebuild [new file with mode: 0644]

diff --git a/sci-libs/shapelib/shapelib-1.4.0-r1.ebuild b/sci-libs/shapelib/shapelib-1.4.0-r1.ebuild
new file mode 100644 (file)
index 0000000..259db71
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/proj"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+       rm -r m4/* || die
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --includedir=/usr/include/libshp
+}
+
+src_install() {
+       use doc && HTML_DOCS=( web/. )
+       default
+
+       if ! use static-libs; then
+               find "${D}" \( -name '*.la' -o -name '*.a' \) -delete || die
+       fi
+}