sys-libs/musl-nscd: bump to 1.0.2
authorPetr Vaněk <arkamar@atlas.cz>
Mon, 14 Oct 2019 08:18:00 +0000 (10:18 +0200)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 15 Oct 2019 13:28:35 +0000 (09:28 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
sys-libs/musl-nscd/Manifest [new file with mode: 0644]
sys-libs/musl-nscd/musl-nscd-1.0.2.ebuild [new file with mode: 0644]

diff --git a/sys-libs/musl-nscd/Manifest b/sys-libs/musl-nscd/Manifest
new file mode 100644 (file)
index 0000000..72daae6
--- /dev/null
@@ -0,0 +1 @@
+DIST musl-nscd-1.0.2.tar.gz 44912 BLAKE2B 8a496c941232ba617b8468351cbbb780b1decc2c162210f939abb3baa430a5f5a79e21fcd3aadac2cbe62820452fc18001edc7ebc13cae7a6ab768353c45235f SHA512 45cd73f1e0eee7b32c3dcdfa96c0a11379f6208389b87fee97016af0ecb19e9e7d2a2f10e0df6e5ed8a6ad4bbbef70c01cd31ac3631fb1bcce6e69bf48843a3d
diff --git a/sys-libs/musl-nscd/musl-nscd-1.0.2.ebuild b/sys-libs/musl-nscd/musl-nscd-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..b474449
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
+HOMEPAGE="https://github.com/pikhq/musl-nscd"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
+       EGIT_BRANCH=master
+else
+       SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="minimal"
+
+src_prepare() {
+       eapply_user
+
+       sed -i '/LDFLAGS_AUTO=-s/d' configure || die 'Cannot patch configure file'
+}
+
+src_install() {
+       if use minimal; then
+               emake DESTDIR="${D}" install-headers
+       else
+               emake DESTDIR="${D}" install
+
+               newinitd "${FILESDIR}"/nscd.initd nscd
+               systemd_dounit "${FILESDIR}"/nscd.service
+               systemd_newtmpfilesd "${FILESDIR}"/nscd.tmpfilesd nscd.conf
+
+               dodoc README
+       fi
+}