media-libs/vigra: Disable more tests
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 27 Nov 2019 14:41:48 +0000 (15:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 27 Nov 2019 14:42:48 +0000 (15:42 +0100)
Bug: https://bugs.gentoo.org/701328
Package-Manager: Portage-2.3.80, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/vigra/vigra-1.11.1-r3.ebuild
media-libs/vigra/vigra-9999.ebuild

index f2b096eaf5199715f128e7073c2770a2e9f9896a..d38b643763a91c3d6ec7cf5c811d6b24e4d46cd6 100644 (file)
@@ -93,7 +93,11 @@ src_prepare() {
        sed -i -e '/env/s:python:python3:' config/vigra-config.in || die
 
        use doc || cmake_comment_add_subdirectory docsrc
-       use test || cmake_comment_add_subdirectory test
+
+       if ! use test; then
+               cmake_comment_add_subdirectory test
+               sed -e "/ADD_SUBDIRECTORY.*test/s/^/#DONT /" -i vigranumpy/CMakeLists.txt || die
+       fi
 }
 
 src_configure() {
index c1094b892655760cddcf25aa0724c3aea8f0cccd..289fe0492523ffe2c7689445c7078e6b69e029e6 100644 (file)
@@ -99,7 +99,10 @@ src_prepare() {
        # Don't use python_fix_shebang because we can't put this behind USE="python"
        sed -i -e '/env/s:python:python3:' config/vigra-config.in || die
 
-       use test || cmake_comment_add_subdirectory test
+       if ! use test; then
+               cmake_comment_add_subdirectory test
+               sed -e "/ADD_SUBDIRECTORY.*test/s/^/#DONT /" -i vigranumpy/CMakeLists.txt || die
+       fi
 }
 
 src_configure() {