net-misc/whois: Revbump to fix automagic dep on sys-libs/libxcrypt
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 20 Apr 2020 10:05:18 +0000 (12:05 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 20 Apr 2020 10:19:38 +0000 (12:19 +0200)
Thanks-to: Eugene Shalygin <eugene.shalygin@gmail.com>
Closes: https://bugs.gentoo.org/718104
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch [new file with mode: 0644]
net-misc/whois/metadata.xml
net-misc/whois/whois-5.5.6-r1.ebuild [moved from net-misc/whois/whois-5.5.6.ebuild with 88% similarity]
net-misc/whois/whois-9999.ebuild
profiles/arch/alpha/package.use.mask
profiles/arch/arm/package.use.mask
profiles/arch/arm64/package.use.mask
profiles/arch/ia64/package.use.mask
profiles/arch/powerpc/package.use.mask

diff --git a/net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch b/net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch
new file mode 100644 (file)
index 0000000..f7bafd5
--- /dev/null
@@ -0,0 +1,19 @@
+We don't want libxcrypt being detected automagically.
+Reverting upstream stupidity.
+
+--- whois-5.5.6/Makefile
++++ whois-5.5.6/Makefile
+@@ -55,12 +55,9 @@
+ DEFS += -DHAVE_ICONV
+ endif
+-ifeq ($(shell $(PKG_CONFIG) --exists 'libxcrypt >= 4.1' || echo NO),)
++ifdef HAVE_XCRYPT
+ DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT $(shell $(PKG_CONFIG) --cflags libcrypt)
+ mkpasswd_LDADD += $(shell $(PKG_CONFIG) --libs libcrypt)
+-else ifdef HAVE_XCRYPT
+-DEFS += -DHAVE_XCRYPT_H -DHAVE_LINUX_CRYPT_GENSALT
+-mkpasswd_LDADD += -lxcrypt
+ else ifdef HAVE_LIBOWCRYPT
+ # owl and openSUSE have crypt_gensalt(3) in libowcrypt
+ DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT -D_OW_SOURCE
index fcd1dc3acbf9b8d5b12e4185ccc70cfb1cd4bf5a..742ee751212e99ff27a7ab63b3b2fe746a4d11b3 100644 (file)
@@ -5,6 +5,9 @@
                <email>base-system@gentoo.org</email>
                <name>Gentoo Base System</name>
        </maintainer>
+       <use>
+               <flag name="xcrypt">Enable crypt through <pkg>sys-libs/libxcrypt</pkg> package</flag>
+       </use>
        <upstream>
                <remote-id type="github">rfc1036/whois</remote-id>
        </upstream>
similarity index 88%
rename from net-misc/whois/whois-5.5.6.ebuild
rename to net-misc/whois/whois-5.5.6-r1.ebuild
index d99078f32be72de75a1f3c2e228ffaae3c60ef81..33c2eb43e69e8c435ba4abb998fabd938e7334c9 100644 (file)
@@ -18,12 +18,15 @@ else
 fi
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="iconv idn nls"
+IUSE="iconv idn nls xcrypt"
 RESTRICT="test" #59327
 
-RDEPEND="iconv? ( virtual/libiconv )
+RDEPEND="
+       iconv? ( virtual/libiconv )
        idn? ( net-dns/libidn2:= )
-       nls? ( virtual/libintl )"
+       nls? ( virtual/libintl )
+       xcrypt? ( >=sys-libs/libxcrypt-4.1 )
+"
 DEPEND="${RDEPEND}"
 BDEPEND="
        app-arch/xz-utils
@@ -36,6 +39,7 @@ BDEPEND="
 PATCHES=(
        "${FILESDIR}"/${PN}-4.7.2-config-file.patch
        "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+       "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
 )
 
 src_prepare() {
@@ -57,6 +61,7 @@ src_compile() {
        unset HAVE_ICONV HAVE_LIBIDN
        use iconv && export HAVE_ICONV=1
        use idn && export HAVE_LIBIDN=1
+       use xcrypt && export HAVE_XCRYPT=1
        tc-export CC
        emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
 }
index 84b8abe1134bea9d0b8132df4992c929b6c71574..8aecce2f7642e11525267b615e83b1b9c8503bf5 100644 (file)
@@ -18,12 +18,15 @@ else
 fi
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="iconv idn nls"
+IUSE="iconv idn nls xcrypt"
 RESTRICT="test" #59327
 
-RDEPEND="iconv? ( virtual/libiconv )
+RDEPEND="
+       iconv? ( virtual/libiconv )
        idn? ( net-dns/libidn2:= )
-       nls? ( virtual/libintl )"
+       nls? ( virtual/libintl )
+       xcrypt? ( >=sys-libs/libxcrypt-4.1 )
+"
 DEPEND="${RDEPEND}"
 BDEPEND="
        app-arch/xz-utils
@@ -34,6 +37,7 @@ BDEPEND="
 PATCHES=(
        "${FILESDIR}"/${PN}-4.7.2-config-file.patch
        "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+       "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
 )
 
 src_prepare() {
@@ -55,6 +59,7 @@ src_compile() {
        unset HAVE_ICONV HAVE_LIBIDN
        use iconv && export HAVE_ICONV=1
        use idn && export HAVE_LIBIDN=1
+       use xcrypt && export HAVE_XCRYPT=1
        tc-export CC
        emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
 }
index 496b26593821facac07429bc97098a60e517d591..25829fd471210fe051626a715a02d10073a08337 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on alpha
+net-misc/whois xcrypt
+
 # Matt Turner <mattst88@gentoo.org> (2020-03-17)
 # Requires an insane (and always growing) number of ruby deps
 sys-block/thin-provisioning-tools test
index f849b05335f306e828d339659c8e82d5c1c023ba..28cd67fcbe8ce47a26fea5e2233aef034bde500a 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on arm
+net-misc/whois xcrypt
+
 # Ettore Di Giacinto <mudler@gentoo.org> (2016-11-10)
 # Dependency has no stable keyword
 # and as for now we have only stable mate versions
index 5109144318924de40267631529b62fbf5409be8a..97105c1da2ff1a63f878fd507829a2a262b36e46 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on arm64
+net-misc/whois xcrypt
+
 # Ettore Di Giacinto <mudler@gentoo.org> (2016-11-10)
 # Dependency has no stable keyword
 # and as for now we have only stable mate versions
index c69d8ff9c59035f5ce1d2d4be232f7b656d5193c..871580a53b781d8cb87a92f0d9509b5b48f1ec89 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on ia64
+net-misc/whois xcrypt
+
 # Mikle Kolyada <zlogene@gentoo.org> (2020-04-20)
 # dev-lang/ruby is not keyworded (a dep)
 app-text/texlive context l10n_ja
index 02e846ab33f30930e1a5cdd1cd9ea503ea5d88eb..7f4e68052f34d2d4ff7f1f7d7a385d1b6b69df2b 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on ppc
+net-misc/whois xcrypt
+
 # Patrick McLean <chutzpah@gentoo.org> (2020-04-03)
 # Lots of deps for little gain
 dev-python/joblib doc