app-crypt/certbot-apache: 0.35.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 5 Jun 2019 22:29:13 +0000 (17:29 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 5 Jun 2019 22:30:33 +0000 (17:30 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.14
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot-apache/Manifest
app-crypt/certbot-apache/certbot-apache-0.35.0.ebuild [new file with mode: 0644]

index 8072b2bea212db7fc53cb80fa0086ab3b79b555e..cdeb26cd910de425ae3d9647cd30d0ed5b4748b4 100644 (file)
@@ -1,3 +1,4 @@
 DIST certbot-0.32.0.tar.gz 1284873 BLAKE2B c3fa538de87b67680a7bc7465d77ab2947606aec4def3717b5d942c83254ff758d751e137bfe33cb6f9362a11a9bad7fba0337927b638f3af7ddf304d408c447 SHA512 fa61e975d2ce09efa3570118f220cd9f9d2fc8d5ab408feb4c4e50bfa795cb28be6c7a78497fb10bc91e577e908126988197ae5d016be4823c5c4ddb68cbf5a4
 DIST certbot-0.33.1.tar.gz 1304071 BLAKE2B 400c12ce254780fc0f336bbcff7917ba1ef4c6a0a708fb9607b79f8e966720a77adea9e56dc110c9424978d18eff15bd372141a0fc79edfb9f8fcc41f5f09f2b SHA512 055030e1ab1d3eb57b980c44732c8ec623d99de2d797a2b825bd2b816fce5b4c4d63d09178eb0a79fb83d991d63f00a149cc043067a2ae42a0ddcaa4fd329979
 DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
+DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
diff --git a/app-crypt/certbot-apache/certbot-apache-0.35.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.35.0.ebuild
new file mode 100644 (file)
index 0000000..3a00f63
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+       S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+       >=app-crypt/certbot-0.34.0[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       dev-python/python-augeas[${PYTHON_USEDEP}]
+       dev-python/zope-component[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+       dev-python/nose[${PYTHON_USEDEP}] )
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       nosetests || die
+}