dev-python/QtPy: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:28:59 +0000 (10:28 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:29:55 +0000 (10:29 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/QtPy/QtPy-1.9.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/QtPy/QtPy-1.9.0-r2.ebuild b/dev-python/QtPy/QtPy-1.9.0-r2.ebuild
new file mode 100644 (file)
index 0000000..a258ad5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstraction layer for PyQt5/PySide"
+HOMEPAGE="https://github.com/spyder-ide/qtpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="designer gui opengl svg testlib webengine"
+
+RDEPEND="
+       dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?]
+       gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
+       testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
+       webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+       default
+
+       sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
+       sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
+       sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
+}