Rev bump fixing bsd build, thanks to Timothy Redaelli <drizzt@gentoo.org>
authorAlexis Ballier <aballier@gentoo.org>
Thu, 30 Nov 2006 19:39:20 +0000 (19:39 +0000)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 30 Nov 2006 19:39:20 +0000 (19:39 +0000)
Package-Manager: portage-2.1.2_rc2-r3

media-libs/portaudio/ChangeLog
media-libs/portaudio/files/digest-portaudio-18.1-r6 [new file with mode: 0644]
media-libs/portaudio/files/portaudio-18.1-r6-Makefile [new file with mode: 0644]
media-libs/portaudio/portaudio-18.1-r6.ebuild [new file with mode: 0644]

index 801fe17e52b14936fa8673027e2ddc5de21bbe7c..c49fd03d8a2238158700e41304231f23b7eb0fbb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-libs/portaudio
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.36 2006/11/23 19:08:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.37 2006/11/30 19:39:20 aballier Exp $
+
+*portaudio-18.1-r6 (30 Nov 2006)
+
+  30 Nov 2006; Alexis Ballier <aballier@gentoo.org>
+  +files/portaudio-18.1-r6-Makefile, +portaudio-18.1-r6.ebuild:
+  Rev bump fixing bsd build, thanks to Timothy Redaelli <drizzt@gentoo.org>
 
   23 Nov 2006; <blubb@gentoo.org> portaudio-18.1-r5.ebuild:
   stable on amd64
diff --git a/media-libs/portaudio/files/digest-portaudio-18.1-r6 b/media-libs/portaudio/files/digest-portaudio-18.1-r6
new file mode 100644 (file)
index 0000000..f45c914
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ce66a732d263fde2b5ad2262ef37a691 portaudio_v18_1.zip 550130
+RMD160 3352d70225a81aae80eefabc3701658da0c750c2 portaudio_v18_1.zip 550130
+SHA256 9da7f1ba0b8029f934d5a8300199e29095127e6abfa03dbb3c1ce40e10751f0a portaudio_v18_1.zip 550130
diff --git a/media-libs/portaudio/files/portaudio-18.1-r6-Makefile b/media-libs/portaudio/files/portaudio-18.1-r6-Makefile
new file mode 100644 (file)
index 0000000..905d29f
--- /dev/null
@@ -0,0 +1,61 @@
+# Make PortAudio for Linux
+# Updated 2001/08/25 Bill Eldridge bill@rfa.org
+# Updated 2001/10/16, philburk@softsynth.com, s/unix_oss/unix_oss/
+# Updated 2002/04/30 Bill Eldridge bill@rfa.org
+#     Made the libinstall and tests compile a bit cleaner
+# Updated 2005/07/22 Jeremy Huddleston eradicator@gentoo.org
+
+# A pretty bare makefile, that figures out all the test files
+# and compiles them against the library in the pa_unix_oss directory.
+
+# Do "make all" and then when happy, "make libinstall"
+# (if not happy, "make clean")
+
+# The ldconfig stuff in libinstall is the wrong way to do it - 
+# someone tell me the right way, please
+
+LIBS =  -lm -lpthread
+
+CFLAGS = -O2
+
+LIBFILES:= ./pa_common/pa_lib.c ./pa_unix_oss/pa_unix_oss.c ./pa_unix_oss/pa_unix.c
+
+VERSION=18
+
+CC=gcc
+LD=ld
+AR=ar
+RANLIB=ranlib
+LN=ln
+CP=cp
+MKDIR=mkdir
+
+prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+
+all: libportaudio.so libportaudio.a
+
+%.lo : %.c
+       $(CC) -fPIC $(CFLAGS) -c -I./pa_common $? -o $@
+
+.c.o:
+       $(CC) $(CFLAGS) -c -I./pa_common $? -o $@
+
+libportaudio.so.$(VERSION): $(LIBFILES:.c=.lo)
+       $(LD) -shared $(LIBS) -soname $@ -o $@ $?
+
+libportaudio.so: libportaudio.so.$(VERSION)
+       $(LN) -s $? $@
+
+libportaudio.a: $(LIBFILES:.c=.o)
+       $(AR) ruv $@ $?
+       $(RANLIB) $@
+
+install: libportaudio.so libportaudio.a
+       $(MKDIR) -p $(DESTDIR)$(includedir)/portaudio
+       $(MKDIR) -p $(DESTDIR)$(libdir)
+       $(CP) -p libportaudio.so.$(VERSION) libportaudio.a $(DESTDIR)$(libdir)
+       $(CP) -p pa_common/portaudio.h $(DESTDIR)$(includedir)/portaudio
+       $(LN) -s libportaudio.so.$(VERSION) $(DESTDIR)$(libdir)/libportaudio.so
+       $(LN) -s portaudio/portaudio.h $(DESTDIR)$(includedir)/portaudio.h
diff --git a/media-libs/portaudio/portaudio-18.1-r6.ebuild b/media-libs/portaudio/portaudio-18.1-r6.ebuild
new file mode 100644 (file)
index 0000000..7b2685a
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/portaudio-18.1-r6.ebuild,v 1.1 2006/11/30 19:39:20 aballier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN}_v${PV/./_}
+DESCRIPTION="An open-source cross platform audio API."
+HOMEPAGE="http://www.portaudio.com"
+SRC_URI="http://www.portaudio.com/archives/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="18"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+
+       if use userland_Darwin ; then
+               cp "${FILESDIR}"/${P}-Makefile.macos "${S}"/Makefile
+       else
+               cp "${FILESDIR}"/${PF}-Makefile "${S}"/Makefile
+       fi
+       # Fix deprecated includes
+       fgrep --null -lr malloc.h "${S}" | xargs -0 sed -i 's/malloc.h/stdlib.h/'
+       fgrep --null -lr machine/soundcard.h "${S}" | xargs -0 sed -i 's/machine\/soundcard.h/sys\/soundcard.h/'
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" LD="$(tc-getLD)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+       make DESTDIR="${D}" libdir="/usr/$(get_libdir)" install || die
+       fperms 644 /usr/include/portaudio/portaudio.h
+       dodoc docs/*
+}