dev-python/watchdog: python3_6 added
authorAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 13:11:22 +0000 (20:11 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 13:11:22 +0000 (20:11 +0700)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/watchdog/watchdog-0.8.3-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/watchdog/watchdog-0.8.3-r2.ebuild b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
new file mode 100644 (file)
index 0000000..40fd632
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: f7a9a577d9772b9743b2ef7fdb310ae950383ed2 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       dev-python/argh[${PYTHON_USEDEP}]
+       dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+               )"
+
+python_test() {
+       esetup.py test
+}
+
+pkg_postinst() {
+       optfeature "Bash completion" dev-python/argcomplete
+}