dev-erlang/p1_oauth2: Add new package
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 6 Jun 2016 22:17:10 +0000 (23:17 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Tue, 7 Jun 2016 22:20:34 +0000 (23:20 +0100)
It is debundled from net-im/ejabberd-16.04 and therefore inherits
keywords from ejabberd: ~amd64, ~arm, ~ppc and ~x86. ~ia64 and ~sparc
are not inherited because other dependency is missing these keywords and
there's no chance it can get them any time soon.

Package-Manager: portage-2.3.0_rc1

dev-erlang/p1_oauth2/Manifest [new file with mode: 0644]
dev-erlang/p1_oauth2/metadata.xml [new file with mode: 0644]
dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild [new file with mode: 0644]

diff --git a/dev-erlang/p1_oauth2/Manifest b/dev-erlang/p1_oauth2/Manifest
new file mode 100644 (file)
index 0000000..bf224a1
--- /dev/null
@@ -0,0 +1 @@
+DIST p1_oauth2-0.6.1.tar.gz 212804 SHA256 86e4d93f0206135bc6017b6001d061305513917f79c53294e534d6e66fd54727 SHA512 2509d48775579a26178fb5a082e628a8487c986b1b4d4abe974b653a1e0b7605bed934d59f6d62927582bdb95a53ba454816d326d99a77c5360928c4973ade4a WHIRLPOOL 1d5583e2d3a626983849ecad11a58adfd53220cfc6cadb345eb99ba7abbc2c2da3fa7a43c302d18aa7a0132db374a21743cb392938a0d9142f69587121d13ad3
diff --git a/dev-erlang/p1_oauth2/metadata.xml b/dev-erlang/p1_oauth2/metadata.xml
new file mode 100644 (file)
index 0000000..674f5ad
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>aidecoe@gentoo.org</email>
+               <name>Amadeusz Żołnowski</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
new file mode 100644 (file)
index 0000000..3330596
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+       test? (
+               >=dev-erlang/meck-0.8.3
+               >=dev-erlang/proper-1.1_p20150814
+       )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md  README.md )
+
+src_prepare() {
+       rebar_src_prepare
+       rebar_remove_deps rebar.test.config
+}
+
+src_test() {
+       erebar -C rebar.test.config compile eunit
+}