Version bump, with updated filename patch, fixed gtk+ detection and added missing...
authorMichele Noberasco <s4t4n@gentoo.org>
Mon, 22 Jan 2007 10:59:52 +0000 (10:59 +0000)
committerMichele Noberasco <s4t4n@gentoo.org>
Mon, 22 Jan 2007 10:59:52 +0000 (10:59 +0000)
Package-Manager: portage-2.1.1-r2

games-engines/gargoyle/ChangeLog
games-engines/gargoyle/files/digest-gargoyle-20060917 [new file with mode: 0644]
games-engines/gargoyle/files/filename-friendliness-20060917.patch [new file with mode: 0644]
games-engines/gargoyle/gargoyle-20060917.ebuild [new file with mode: 0644]

index 58e75bfd05021108aa861efec951dcaab5a0237f..27a41b6f3e7a7f8ebad9bdde31b6df9fc301790e 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for games-engines/gargoyle
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.4 2006/08/24 11:09:51 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.5 2007/01/22 10:59:52 s4t4n Exp $
+
+*gargoyle-20060917 (22 Jan 2007)
+
+  22 Jan 2007; Michele Noberasco <s4t4n@gentoo.org> gargoyle-20060917.ebuild:
+  Version bump, with updated filenames patch. Also, added missing sdl-sound and
+  sdl-mixer dependancies, and fixed gtk+ detection. Closes bug #157207.
+  gargoyle-20060703:
+  Wiped out previous version.
 
   24 Aug 2006; Michele Noberasco <s4t4n@gentoo.org> gargoyle-20060703.ebuild:
   Removed duplicate 'inherit eutils' entry.. Closes bug #144950.
diff --git a/games-engines/gargoyle/files/digest-gargoyle-20060917 b/games-engines/gargoyle/files/digest-gargoyle-20060917
new file mode 100644 (file)
index 0000000..fb141c1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 19467db0e693c31810153ca8aaf7f915 gargoyle-2006-09-17-source.zip 9714916
+RMD160 86e832323f8da96004460c7fa5b1054717817884 gargoyle-2006-09-17-source.zip 9714916
+SHA256 3a39e8e8809a8d942bb5ae71b8f64e4f4f4ecbf2cd1e7de0ed40fd58ea2f7ce0 gargoyle-2006-09-17-source.zip 9714916
diff --git a/games-engines/gargoyle/files/filename-friendliness-20060917.patch b/games-engines/gargoyle/files/filename-friendliness-20060917.patch
new file mode 100644 (file)
index 0000000..0d77d55
--- /dev/null
@@ -0,0 +1,228 @@
+diff -rU2 gargoyle-orig/garglk/launcher.sh gargoyle/garglk/launcher.sh
+--- gargoyle-orig/garglk/launcher.sh   2007-01-09 12:55:49.000000000 -0800
++++ gargoyle/garglk/launcher.sh        2007-01-09 12:57:07.000000000 -0800
+@@ -45,25 +45,25 @@
+ case "$lowpath" in
+-    *.taf ) $dirpath/scare "$1" ;;
+-    *.dat ) $dirpath/advsys "$1" ;;
+-    *.agx ) $dirpath/agility "$1" ;;
+-    *.d\$\$ ) $dirpath/agility "$1" ;;
+-    *.acd ) $dirpath/alan2 "$1" ;;
+-    *.a3c ) $dirpath/alan3 "$1" ;;
+-    *.ulx ) $dirpath/git "$1" ;;
+-    *.hex ) $dirpath/hugo "$1" ;;
+-    *.l9  ) $dirpath/level9 "$1" ;;
+-    *.sna ) $dirpath/level9 "$1" ;;
+-    *.mag ) $dirpath/magnetic "$1" ;;
+-    *.gam ) $dirpath/tadsr "$1" ;;
+-    *.t3  ) $dirpath/tadsr "$1" ;;
+-    *.z?  ) $dirpath/frotz "$1" ;;
++    *.taf ) $dirpath/gargoyle-scare "$1" ;;
++    *.dat ) $dirpath/gargoyle-advsys "$1" ;;
++    *.agx ) $dirpath/gargoyle-agility "$1" ;;
++    *.d\$\$ ) $dirpath/gargoyle-agility "$1" ;;
++    *.acd ) $dirpath/gargoyle-alan2 "$1" ;;
++    *.a3c ) $dirpath/gargoyle-alan3 "$1" ;;
++    *.ulx ) $dirpath/gargoyle-git "$1" ;;
++    *.hex ) $dirpath/gargoyle-hugo "$1" ;;
++    *.l9  ) $dirpath/gargoyle-level9 "$1" ;;
++    *.sna ) $dirpath/gargoyle-level9 "$1" ;;
++    *.mag ) $dirpath/gargoyle-magnetic "$1" ;;
++    *.gam ) $dirpath/gargoyle-tadsr "$1" ;;
++    *.t3  ) $dirpath/gargoyle-tadsr "$1" ;;
++    *.z?  ) $dirpath/gargoyle-frotz "$1" ;;
+-    *.blb    ) $dirpath/git "$1" ;;
+-    *.blorb  ) $dirpath/git "$1" ;;
+-    *.glb    ) $dirpath/git "$1" ;;
+-    *.gblorb ) $dirpath/git "$1" ;;
+-    *.zlb    ) $dirpath/frotz "$1" ;;
+-    *.zblorb ) $dirpath/frotz "$1" ;;
++    *.blb    ) $dirpath/gargoyle-git "$1" ;;
++    *.blorb  ) $dirpath/gargoyle-git "$1" ;;
++    *.glb    ) $dirpath/gargoyle-git "$1" ;;
++    *.gblorb ) $dirpath/gargoyle-git "$1" ;;
++    *.zlb    ) $dirpath/gargoyle-frotz "$1" ;;
++    *.zblorb ) $dirpath/gargoyle-frotz "$1" ;;
+     * ) echo "gargoyle: Unknown file type: $1" ;;
+diff -rU2 gargoyle-orig/tads/Jamfile gargoyle/tads/Jamfile
+--- gargoyle-orig/tads/Jamfile 2007-01-09 12:55:51.000000000 -0800
++++ gargoyle/tads/Jamfile      2007-01-09 12:57:57.000000000 -0800
+@@ -62,5 +62,5 @@
+ SEARCH_SOURCE = $(SUBDIR) ;
+-Main tadsr :
++Main gargoyle-tadsr :
+       t23run.cpp
+       osansi1.c osansi2.c osansi3.c
+@@ -75,8 +75,8 @@
+       ;
+-LinkLibraries tadsr : libtads2 libtads3 ;
++LinkLibraries gargoyle-tadsr : libtads2 libtads3 ;
+-LINK on tadsr$(SUFEXE) = $(C++) ;
++LINK on gargoyle-tadsr$(SUFEXE) = $(C++) ;
+-APPS += tadsr ;
++APPS += gargoyle-tadsr ;
+diff -rU2 gargoyle-orig/terps/Jamfile gargoyle/terps/Jamfile
+--- gargoyle-orig/terps/Jamfile        2007-01-09 12:55:56.000000000 -0800
++++ gargoyle/terps/Jamfile     2007-01-09 13:00:02.000000000 -0800
+@@ -32,9 +32,9 @@
+     SubDirCcFlags -w ;
+-    Main advsys :
++    Main gargoyle-advsys :
+         advmsg.c advtrm.c advprs.c advdbs.c advint.c advjunk.c advexe.c
+         glkstart.c ;
+-    APPS += advsys ;
++    APPS += gargoyle-advsys ;
+ }
+@@ -58,5 +58,5 @@
+     SubDirCcFlags -DGLK_ANSI_ONLY ;
+-    Main agility :
++    Main gargoyle-agility :
+         agtread.c gamedata.c util.c agxfile.c auxfile.c filename.c
+         parser.c exec.c runverb.c metacommand.c savegame.c debugcmd.c
+@@ -65,5 +65,5 @@
+         ;
+-    APPS += agility ;
++    APPS += gargoyle-agility ;
+ }
+@@ -83,5 +83,5 @@
+     SubDirCcFlags -funsigned-char -Wno-parentheses -DGLK -DREVERSED ;
+-    Main alan2 :
++    Main gargoyle-alan2 :
+         arun.c main.c debug.c args.c exe.c inter.c parse.c rules.c stack.c
+         decode.c term.c reverse.c readline.c params.c sysdep.c
+@@ -89,5 +89,5 @@
+         ;
+-    APPS += alan2 ;
++    APPS += gargoyle-alan2 ;
+ }
+@@ -106,5 +106,5 @@
+     SubDirCcFlags -funsigned-char -DGLK ;
+-    Main alan3 :
++    Main gargoyle-alan3 :
+         arun.c main.c debug.c args.c exe.c inter.c parse.c rules.c stack.c
+         decode.c term.c reverse.c readline.c params.c sysdep.c
+@@ -113,5 +113,5 @@
+         ;
+-    APPS += alan3 ;
++    APPS += gargoyle-alan3 ;
+ }
+@@ -126,5 +126,5 @@
+     ObjDir frotz ;
+-    Main frotz :
++    Main gargoyle-frotz :
+         buffer.c err.c fastmem.c files.c
+         input.c main.c math.c object.c process.c quetzal.c random.c
+@@ -133,5 +133,5 @@
+         ;
+-    APPS += frotz ;
++    APPS += gargoyle-frotz ;
+ }
+@@ -150,5 +150,5 @@
+     SubDirCcFlags -DUSE_INLINE ;
+-    Main git :
++    Main gargoyle-git :
+         git.c memory.c compiler.c opcodes.c operands.c
+         peephole.c terp.c glkop.c search.c git_unix.c
+@@ -156,5 +156,5 @@
+         ;
+-    APPS += git ;
++    APPS += gargoyle-git ;
+ }
+@@ -171,10 +171,10 @@
+     if $(OS) != MINGW { SubDirCcFlags -DOS_UNIX ; }
+-    Main glulxe :
++    Main gargoyle-glulxe :
+         main.c files.c vm.c exec.c funcs.c operand.c string.c glkop.c
+         serial.c search.c gestalt.c osdepend.c unixstrt.c
+         ;
+-    APPS += glulxe ;
++    APPS += gargoyle-glulxe ;
+ }
+@@ -206,10 +206,10 @@
+         [ FDirName $(SUBDIR) heglk ] ;
+-    Main hugo :
++    Main gargoyle-hugo :
+         he.c heexpr.c hemisc.c heobject.c heparse.c heres.c herun.c heset.c 
+         stringfn.c heglk.c heglkunix.c
+         ;
+-    APPS += hugo ;
++    APPS += gargoyle-hugo ;
+ }
+@@ -237,7 +237,7 @@
+         [ FDirName $(SUBDIR) Glk ] ;
+-    Main level9 : level9.c glk.c ;
++    Main gargoyle-level9 : level9.c glk.c ;
+-    APPS += level9 ;
++    APPS += gargoyle-level9 ;
+ }
+@@ -268,7 +268,7 @@
+     # SubDirCcFlags -DNOBORDER ;
+-    Main magnetic : emu.c glk.c ;
++    Main gargoyle-magnetic : emu.c glk.c ;
+-    APPS += magnetic ;
++    APPS += gargoyle-magnetic ;
+ }
+@@ -315,8 +315,8 @@
+         sound.c graphics.c blorb.c 
+         ;
+-    Main nitfol : main.c startunix.c ;
+-    LinkLibraries nitfol : libnitfol ;
++    Main gargoyle-nitfol : main.c startunix.c ;
++    LinkLibraries gargoyle-nitfol : libnitfol ;
+-    APPS += nitfol ;
++    APPS += gargoyle-nitfol ;
+ }
+@@ -336,5 +336,5 @@
+     }
+-    Main scare :
++    Main gargoyle-scare :
+         sctafpar.c sctaffil.c scprops.c scvars.c scexpr.c scprintf.c
+         scinterf.c scparser.c sclibrar.c scrun.c scevents.c scnpcs.c
+@@ -343,5 +343,5 @@
+         ;
+-    APPS += scare ;
++    APPS += gargoyle-scare ;
+ }
diff --git a/games-engines/gargoyle/gargoyle-20060917.ebuild b/games-engines/gargoyle/gargoyle-20060917.ebuild
new file mode 100644 (file)
index 0000000..9cab867
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917.ebuild,v 1.1 2007/01/22 10:59:52 s4t4n Exp $
+
+inherit eutils
+
+MY_PV="2006-09-17"
+MY_P=${PN}-${MY_PV}
+S="${WORKDIR}/${PN}/"
+DESCRIPTION="Beautified Glk library and interactive fiction multi-interpreter"
+HOMEPAGE="http://ccxvii.net/gargoyle/"
+SRC_URI="http://ccxvii.net/gargoyle/download/${MY_P}-source.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=media-libs/freetype-2.1.9-r1
+       >=x11-libs/gtk+-2.10.6
+       >=dev-libs/glib-2.12.4-r1
+       >=media-libs/jpeg-6b-r5
+       >=media-libs/libpng-1.2.8
+       >=sys-libs/zlib-1.2.3
+       >=media-libs/fmod-3.74
+       >=media-libs/sdl-sound-1.0.1-r1
+       >=media-libs/sdl-mixer-1.2.7"
+
+DEPEND="${RDEPEND}
+       >=dev-util/jam-2.5-r3
+       app-arch/unzip
+       >=sys-apps/sed-4.1.4-r1"
+
+src_unpack()
+{
+       unpack ${A}
+       cd ${S}
+
+       #Fix file named
+       epatch ${FILESDIR}/filename-friendliness-${PV}.patch
+
+       #Fix gtk+ detection
+       sed -i 's/"pkg-config freetype2 gtk+"/"pkg-config freetype2 gtk+-2.0"/' ${S}/Jamrules
+}
+
+src_compile()
+{
+       jam
+}
+
+src_install()
+{
+       dodoc Readme.txt garglk/TODO licenses/*
+       insinto /etc; newins garglk/garglk.ini garglk.ini
+
+       #Should to copy garglk/garglk.ini to /etc/, but I don't know the syntax
+
+       cd build/linux.release
+       dolib garglk/libgarglk.so
+       dobin advsys/gargoyle-advsys agility/gargoyle-agility alan2/gargoyle-alan2
+       dobin alan3/gargoyle-alan3 garglk/gargoyle git/gargoyle-git
+       dobin hugo/gargoyle-hugo level9/gargoyle-level9 scare/gargoyle-scare
+       dobin tads/gargoyle-tadsr frotz/gargoyle-frotz magnetic/gargoyle-magnetic
+}