app-text/u2ps: Version bump
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 22 Dec 2019 19:46:42 +0000 (20:46 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 22 Dec 2019 19:49:22 +0000 (20:49 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-text/u2ps/Manifest
app-text/u2ps/files/u2ps-1.1-nostrip.patch [new file with mode: 0644]
app-text/u2ps/u2ps-1.1.ebuild [new file with mode: 0644]

index 3de906698921741e2919f6974858278d5a31ba62..1e71263526d04dad9089bf6e02d113a8a0dec365 100644 (file)
@@ -1 +1,2 @@
+DIST u2ps-1.1.tar.gz 110892 BLAKE2B af0dd92d47a8530e8434983132c3bf0f0e6b88ff14cc9d7e73e95c842b4c1dad1b900d91c22a34c8f94373e62382841329e5b2e6b3aa9b51f6e5d6d6d164b596 SHA512 44a470268aafe7b90c17e14a15864924d0ba78b0c8707b9bf076e13b262a9d43d71b6527c5a995f82741e52fe2d07eac6a2626921e7465127a57405d4b5babd3
 DIST u2ps-full-0.8.4.tar.gz 5496922 BLAKE2B 416a206b768328cf1a268b4706578610e6bed45ee7475d52de515e112e51bbfcc777b2f21603826d52da42b9c6a3bd10dd4e95920e77c14e957ad4a6d0888984 SHA512 31e5c22163a934a3e153ec95e2e5dd94ce79f71a72278a386a6446b1dd053161c896344c51b696c37d838eb3f06fa6fe1db6b5daa55812a06467b2525266363e
diff --git a/app-text/u2ps/files/u2ps-1.1-nostrip.patch b/app-text/u2ps/files/u2ps-1.1-nostrip.patch
new file mode 100644 (file)
index 0000000..33ac79c
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ruN u2ps-1.1.orig/Makefile u2ps-1.1/Makefile
+--- u2ps-1.1.orig/Makefile     2019-02-17 20:01:48.000000000 +0100
++++ u2ps-1.1/Makefile  2019-12-22 20:43:17.667058496 +0100
+@@ -18,8 +18,8 @@
+ install:
+       install -dm 0755 $(DESTDIR)$(bindir)
+-      install -sm 0755 u2ps $(DESTDIR)$(bindir)/u2ps
+-      install -sm 0755 psfrem $(DESTDIR)$(bindir)/psfrem
++      install -m 0755 u2ps $(DESTDIR)$(bindir)/u2ps
++      install -m 0755 psfrem $(DESTDIR)$(bindir)/psfrem
+       install -dm 0755 $(DESTDIR)$(basedir)
+       install -dm 0755 $(DESTDIR)$(basedir)/ProcSet
+       install -m 0644 res/*.ps $(DESTDIR)$(basedir)
diff --git a/app-text/u2ps/u2ps-1.1.ebuild b/app-text/u2ps/u2ps-1.1.ebuild
new file mode 100644 (file)
index 0000000..c28a8cc
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="https://github.com/arsv/u2ps"
+SRC_URI="https://github.com/arsv/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-nostrip.patch" )
+
+src_configure() {
+       # this isnt autoconf, so econf fails...
+       ./configure \
+               --prefix=/usr \
+               --datadir=/usr/share \
+               --mandir=/usr/share/man \
+               --with-gs=/usr/bin/gs \
+               || die 'configure failed'
+}