www-client/weboob: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:03:18 +0000 (22:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:40 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-client/weboob/weboob-1.3.ebuild
www-client/weboob/weboob-9998.ebuild
www-client/weboob/weboob-9999.ebuild

index 13f4e208d43577ef5fe5ef43e56565671fec5eb4..19b1a901b2ffa39d8c3a7acf244274318d47966b 100644 (file)
@@ -44,7 +44,9 @@ RDEPEND="${COMMON_DEPEND}
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/termcolor[${PYTHON_USEDEP}]
        dev-python/unidecode[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/futures[${PYTHON_USEDEP}]
+       ' -2)
        deprecated? ( dev-python/mechanize[${PYTHON_USEDEP}] )
        fast-libs? (
                dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
index 13f4e208d43577ef5fe5ef43e56565671fec5eb4..19b1a901b2ffa39d8c3a7acf244274318d47966b 100644 (file)
@@ -44,7 +44,9 @@ RDEPEND="${COMMON_DEPEND}
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/termcolor[${PYTHON_USEDEP}]
        dev-python/unidecode[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/futures[${PYTHON_USEDEP}]
+       ' -2)
        deprecated? ( dev-python/mechanize[${PYTHON_USEDEP}] )
        fast-libs? (
                dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
index 13f4e208d43577ef5fe5ef43e56565671fec5eb4..19b1a901b2ffa39d8c3a7acf244274318d47966b 100644 (file)
@@ -44,7 +44,9 @@ RDEPEND="${COMMON_DEPEND}
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/termcolor[${PYTHON_USEDEP}]
        dev-python/unidecode[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/futures[${PYTHON_USEDEP}]
+       ' -2)
        deprecated? ( dev-python/mechanize[${PYTHON_USEDEP}] )
        fast-libs? (
                dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]