dev-python/pyotp: Bump to 2.3.0
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 06:05:23 +0000 (08:05 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 07:18:24 +0000 (09:18 +0200)
Closes: https://bugs.gentoo.org/696650
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyotp/Manifest
dev-python/pyotp/pyotp-2.3.0.ebuild [new file with mode: 0644]

index a6f46cb48b25e8d9539cff5a5d2c0dcff8e695d3..4ad525472404aa3be0310804c90573c612e16e57 100644 (file)
@@ -1 +1,2 @@
 DIST pyotp-2.2.6.tar.gz 10602 BLAKE2B 801f48646ff15a039b9295948ed292c3c432f8b0b629d249554259802335b7430a2c82f8c3bee1f54df71b0972ec293d69a2005c35cac120a51cec1a3548b2c1 SHA512 4f962704411ceebff967cf13af5ec5b815da0f82af665a086c4e5d53acc735453d638c65aa2afa40fe546e92d04a9250f6964cb22270a67c9609f8486eb5ba90
+DIST pyotp-2.3.0.tar.gz 11672 BLAKE2B a3d8ca5296b5a8a7aa053b0a0556285c19f335cb1dfb4f892d40fe2d79cc52313af7b31c6ee4afc4eb8c1cd8cb8248442bd1a4868e2bb921a552332a0a283a44 SHA512 4a7a4206134e9a370f7f3c3a9b7e755b75a84e30a320084faf91af5607c4262a6aa76d7b8cefaf284e4cf01faea1df4ca92d871644a14ab56f04693b227485cf
diff --git a/dev-python/pyotp/pyotp-2.3.0.ebuild b/dev-python/pyotp/pyotp-2.3.0.ebuild
new file mode 100644 (file)
index 0000000..f6bc189
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyotp/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest