dev-libs/libinput: bump to 1.3.3
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
Wed, 29 Jun 2016 11:38:10 +0000 (13:38 +0200)
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
Wed, 29 Jun 2016 11:38:10 +0000 (13:38 +0200)
Package-Manager: portage-2.2.28

dev-libs/libinput/Manifest
dev-libs/libinput/libinput-1.3.3.ebuild [new file with mode: 0644]

index 96e6d790fe665155ec3ab58b7b1a8916496288b9..f0aef5fd742e9f3ba8c12e271c4c615c1a167222 100644 (file)
@@ -5,3 +5,4 @@ DIST libinput-1.2.2.tar.xz 857176 SHA256 08ac5b3620d86df1cdb4970c4137c8746c9f4b9
 DIST libinput-1.2.3.tar.xz 860400 SHA256 09b2a9d3a0cc973a9d3fdc7af40162cbef0b16be0a2e415786f83761f519e9f2 SHA512 2b82169a395c4f8b3d9a6250b1e4787b7dac1a0a7ea421036ccbbfdb256c59f848f68233522db977d311a48abfef28b3c3f0b3779254c34469b84c7287a90fbf WHIRLPOOL ce0517cf824193c56a82a1ac61e5c8950e6f7910162c65b996bc0330e2a1fff53a59494b3f516b412995dc9af59c598b3ae6123ce601b32da07a370540705b86
 DIST libinput-1.3.0.tar.xz 878372 SHA256 998a75fb261d161efaa7da44411cdc9a32a953280e4ffc6322ca19f057d0c1ea SHA512 dbd373d7b359419d059a8e6e31a701ccdf786393f5a5c1d97abc00e52ac167b80e7dcca9f9fe09de34812642898b4e19e6723bb5336c039c31012cc148d966aa WHIRLPOOL 1d2beff56b2d7a2327883e50c8a4dfe83531b1c096bf5ce778c10c09beec6cd104ca6c189318383f541912e2b76e287c2d15dc546527e24aadaa1938291351cb
 DIST libinput-1.3.1.tar.xz 880284 SHA256 cdff653d93395c718f367af61fee866914bc45de75ac94abe7dc1b720462aca9 SHA512 b63f28bb99544bea48742669156a8dd6041e00315cbe75849d6bcee2c9f7c0570c9b96e59982cdfe5f972bd15cd97f852038ecce0feaed071fe31cc26a3936e8 WHIRLPOOL f0732988b7f24bf1d1a97210071488925ba139033c374f0b345b45ec74073df3a778189bad0c1c949d26997c4068d9e55ebab386438cc18cea2ca933767ae9da
+DIST libinput-1.3.3.tar.xz 881992 SHA256 30c8edfe47654a38c235ac6b0541d79fd593d010bc18cdda8bd1f6cc6ad8b1ce SHA512 3acfa15ed39bb59fb18e3587718714eb277144069938c609b99a7b861e2fad85426cff840e3914552e98c2d06c010755f82fca705bab211195735a7753e191e9 WHIRLPOOL 928ffc16337e1ab49e577a05b85ddecfa037be2c0d3028d5aad2fc89cc82f30cba312500765d96661248e94b396888819ce4a3d63e6bfc93637575aef496ddcd
diff --git a/dev-libs/libinput/libinput-1.3.3.ebuild b/dev-libs/libinput/libinput-1.3.3.ebuild
new file mode 100644 (file)
index 0000000..8ec94bd
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+       input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+       >=dev-libs/libevdev-0.4
+       >=sys-libs/mtdev-1.1
+       virtual/libudev
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+#      test? (
+#              >=dev-libs/check-0.9.10
+#              dev-util/valgrind
+#              sys-libs/libunwind )
+
+src_prepare() {
+       # Doc handling in kinda strange but everything
+       # is available in the tarball already.
+       sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+               -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+       # gui can be built but will not be installed
+       # building documentation silently fails with graphviz syntax errors
+       econf \
+               --disable-documentation \
+               --disable-event-gui \
+               $(use_enable input_devices_wacom libwacom) \
+               $(use_enable test tests) \
+               --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+       emake install DESTDIR="${D}"
+       dodoc -r doc/html
+       prune_libtool_files
+}