net-wireless/bluez: Backport lots of fixes (from Fedora)...
authorPacho Ramos <pacho@gentoo.org>
Mon, 10 Jun 2019 11:22:54 +0000 (13:22 +0200)
committerPacho Ramos <pacho@gentoo.org>
Mon, 10 Jun 2019 11:22:54 +0000 (13:22 +0200)
- Include multiple fixes backported by Fedora people
- Stop relying on plugdev group and follow upstream policy (#679034)
- Update udevadm PATH for current systemd (#539844)
- Rename USE alsa to midi (#658862)

Closes: https://bugs.gentoo.org/679034
Closes: https://bugs.gentoo.org/658862
Bug: https://bugs.gentoo.org/539844
Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-wireless/bluez/Manifest
net-wireless/bluez/bluez-5.50-r3.ebuild [new file with mode: 0644]
net-wireless/bluez/files/bluez-5.50-sink-connect.patch [new file with mode: 0644]
net-wireless/bluez/files/bluez-udevadm-path-r1.patch [new file with mode: 0644]
net-wireless/bluez/metadata.xml

index 0574b3c3473c927d94eefa4334743fb16159af0e..2de1b406112ea0291377bf3fbbe477c5386a5536 100644 (file)
@@ -1 +1,2 @@
+DIST bluez-5.50-fedora-backports.tar.xz 32232 BLAKE2B 35244036bbe18481e32bef2dcd4a223d44442ce28cee85a3a736bfbf5ee9d74372fa6366dc1102bf86babada608966a8c30b1c2537859a3741c289cabbc76026 SHA512 6d33e8bc67e50dc0d4cee3fa080402a51ddc8b6549f19b6c272de7dc51604eab23f909322f01aaca8a834abdc3cfd0bf24bb8623071af0cf0611d7427c9d8e9a
 DIST bluez-5.50.tar.xz 1755384 BLAKE2B d70763a80fa233cd31fbefc44f73ffceb54c2d7b64ee83df0d2dafb039771d2b18e69dd44b35b2cdf8eee97553c02deca2281f7ec54e958218cf6c4b364a8516 SHA512 64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45
diff --git a/net-wireless/bluez/bluez-5.50-r3.ebuild b/net-wireless/bluez/bluez-5.50-r3.ebuild
new file mode 100644 (file)
index 0000000..c613f12
--- /dev/null
@@ -0,0 +1,267 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 systemd udev user multilib-minimal
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org"
+SRC_URI="
+       mirror://kernel/linux/bluetooth/${P}.tar.xz
+       https://dev.gentoo.org/~pacho/${PN}/${P}-fedora-backports.tar.xz
+"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +obex +readline selinux systemd test test-programs +udev user-session"
+
+# Since this release all remaining extra-tools need readline support, but this could
+# change in the future, hence, this REQUIRED_USE constraint could be dropped
+# again in the future.
+REQUIRED_USE="
+       extra-tools? ( deprecated readline )
+       test? ( ${PYTHON_REQUIRED_USE} )
+       test-programs? ( ${PYTHON_REQUIRED_USE} )
+"
+
+TEST_DEPS="${PYTHON_DEPS}
+       >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       virtual/pkgconfig
+       test? ( ${TEST_DEPS} )
+"
+DEPEND="
+       >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+       >=sys-apps/hwids-20121202.2
+       btpclient? ( >=dev-libs/ell-0.3 )
+       cups? ( net-print/cups:= )
+       mesh? (
+               >=dev-libs/ell-0.3
+               dev-libs/json-c:=
+               sys-libs/readline:0=
+       )
+       midi? ( media-libs/alsa-lib )
+       obex? ( dev-libs/libical:= )
+       readline? ( sys-libs/readline:0= )
+       systemd? (
+               >=sys-apps/dbus-1.6:=[user-session=]
+               sys-apps/systemd
+       )
+       !systemd? ( >=sys-apps/dbus-1.6:= )
+       udev? ( >=virtual/udev-172 )
+"
+RDEPEND="${DEPEND}
+       selinux? ( sec-policy/selinux-bluetooth )
+       test-programs? ( ${TEST_DEPS} )
+"
+
+PATCHES=(
+       # Fix missing header (fixed in 'master')
+       "${FILESDIR}"/${P}-btpclient-header.patch
+
+       # Fix switch to A2DP sink profile
+       "${FILESDIR}"/${P}-sink-connect.patch
+
+       # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+       # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+       "${FILESDIR}"/${PN}-udevadm-path-r1.patch
+
+       # build: Quote systemd variable names, bug #527432
+       # http://article.gmane.org/gmane.linux.bluez.kernel/67230
+       "${FILESDIR}"/${PN}-5.39-systemd-quote.patch
+
+       # Fedora patches
+       # http://www.spinics.net/lists/linux-bluetooth/msg40136.html
+       "${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
+
+       # ???
+       "${FILESDIR}"/0004-agent-Assert-possible-infinite-loop.patch
+)
+
+pkg_setup() {
+       if use test || use test-programs; then
+               python-single-r1_pkg_setup
+       fi
+
+       if ! use udev; then
+               ewarn
+               ewarn "You are installing ${PN} with USE=-udev. This means various bluetooth"
+               ewarn "devices and adapters from Apple, Dell, Logitech etc. will not work,"
+               ewarn "and hid2hci will not be available."
+               ewarn
+       fi
+}
+
+src_prepare() {
+       default
+
+       # Apply Fedora backports
+       eapply "${WORKDIR}"/${P}-fedora-backports/*.patch
+
+       # http://www.spinics.net/lists/linux-bluetooth/msg38490.html
+       if ! use user-session || ! use systemd; then
+               eapply "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
+       fi
+
+       if use cups; then
+               sed -i \
+                       -e "s:cupsdir = \$(libdir)/cups:cupsdir = $(cups-config --serverbin):" \
+                       Makefile.{in,tools} || die
+       fi
+
+       # Broken test https://bugzilla.kernel.org/show_bug.cgi?id=196621
+       sed -i -e '/unit_tests += unit\/test-gatt\b/d' Makefile.am || die
+
+       eautoreconf
+
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myconf=(
+               # readline is automagic when client is enabled
+               # --enable-client always needs readline, bug #504038
+               # --enable-mesh is handled in the same way
+               ac_cv_header_readline_readline_h=$(multilib_native_usex readline)
+               ac_cv_header_readline_readline_h=$(multilib_native_usex mesh)
+       )
+
+       if ! multilib_is_native_abi; then
+               myconf+=(
+                       # deps not used for the library
+                       {DBUS,GLIB}_{CFLAGS,LIBS}=' '
+               )
+       fi
+
+       econf \
+               --localstatedir=/var \
+               --disable-android \
+               --enable-datafiles \
+               --enable-optimization \
+               $(use_enable debug) \
+               --enable-pie \
+               --enable-threads \
+               --enable-library \
+               --enable-tools \
+               --enable-manpages \
+               --enable-monitor \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+               $(multilib_native_use_enable btpclient) \
+               $(multilib_native_use_enable cups) \
+               $(multilib_native_use_enable deprecated) \
+               $(multilib_native_use_enable experimental) \
+               $(multilib_native_use_enable mesh) \
+               $(multilib_native_use_enable midi) \
+               $(multilib_native_use_enable obex) \
+               $(multilib_native_use_enable readline client) \
+               $(multilib_native_use_enable systemd) \
+               $(multilib_native_use_enable test-programs test) \
+               $(multilib_native_use_enable udev) \
+               $(multilib_native_use_enable udev sixaxis)
+}
+
+multilib_src_compile() {
+       if multilib_is_native_abi; then
+               default
+       else
+               emake -f Makefile -f - libs \
+                       <<<'libs: $(lib_LTLIBRARIES)'
+       fi
+}
+
+multilib_src_test() {
+       multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+       if multilib_is_native_abi; then
+               emake DESTDIR="${D}" install
+
+               # Only install extra-tools when relevant USE flag is enabled
+               if use extra-tools; then
+                       ewarn "Upstream doesn't support using this tools and their bugs are"
+                       ewarn "likely to be ignored forever, also that tools can break"
+                       ewarn "without previous announcement."
+                       ewarn "Upstream also states all this tools are not really needed,"
+                       ewarn "then, if you still need to rely on them, you must ask them"
+                       ewarn "to either install that tool by default or add the needed"
+                       ewarn "functionality to the existing 'official' tools."
+                       ewarn "Please report this issues to:"
+                       ewarn "http://www.bluez.org/development/lists/"
+
+                       # Upstream doesn't install this, bug #524640
+                       # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+                       # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+                       # gatttool is only built with readline, bug #530776
+                       dobin attrib/gatttool
+                       dobin tools/btmgmt
+               fi
+
+               # Not installed by default after being built, bug #666756
+               use btpclient && dobin tools/btpclient
+
+               # Unittests are not that useful once installed, so make them optional
+               if use test-programs; then
+                       # example-gatt-client is the only one needing
+                       # python3, the others are python2 only. Remove
+                       # until we see how to pull in python2 and python3
+                       # for runtime
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/example-gatt-server || die
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/example-gatt-client || die
+                       python_fix_shebang "${ED}"/usr/$(get_libdir)/bluez/test
+                       for i in $(find "${ED}"/usr/$(get_libdir)/bluez/test -maxdepth 1 -type f ! -name "*.*"); do
+                               dosym "${i}" /usr/bin/bluez-"${i##*/}"
+                       done
+               fi
+       else
+               emake DESTDIR="${D}" \
+                       install-includeHEADERS \
+                       install-libLTLIBRARIES \
+                       install-pkgconfigDATA
+       fi
+}
+
+multilib_src_install_all() {
+       # We need to ensure obexd can be spawned automatically by systemd
+       # when user-session is enabled:
+       # http://marc.info/?l=linux-bluetooth&m=148096094716386&w=2
+       # https://bugs.gentoo.org/show_bug.cgi?id=577842
+       # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804908
+       # https://bugs.archlinux.org/task/45816
+       # https://bugzilla.redhat.com/show_bug.cgi?id=1318441
+       # https://bugzilla.redhat.com/show_bug.cgi?id=1389347
+       if use user-session && use systemd; then
+               ln -s "${ED}"/usr/lib/systemd/user/obex.service "${ED}"/usr/lib/systemd/user/dbus-org.bluez.obex.service
+       fi
+
+       find "${D}" -name '*.la' -delete || die
+
+       keepdir /var/lib/bluetooth
+
+       # Upstream don't want people to play with them
+       # But we keep installing them due to 'historical' reasons
+       insinto /etc/bluetooth
+       local d
+       for d in input network; do
+               doins profiles/${d}/${d}.conf
+       done
+       doins src/main.conf
+
+       newinitd "${FILESDIR}"/bluetooth-init.d-r4 bluetooth
+
+       einstalldocs
+       use doc && dodoc doc/*.txt
+}
+
+pkg_postinst() {
+       use udev && udev_reload
+       systemd_reenable bluetooth.service
+
+       has_version net-dialup/ppp || elog "To use dial up networking you must install net-dialup/ppp."
+}
diff --git a/net-wireless/bluez/files/bluez-5.50-sink-connect.patch b/net-wireless/bluez/files/bluez-5.50-sink-connect.patch
new file mode 100644 (file)
index 0000000..2093b69
--- /dev/null
@@ -0,0 +1,72 @@
+From 477ecca127c529611adbc53f08039cefaf86305d Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Tue, 26 Jun 2018 13:37:33 +0300
+Subject: policy: Add logic to connect a Sink
+
+If HFP/HSP HS connects and the device also supports a Sink connect it
+as well since some devices (e.g. Sony MW600) may not connect it
+automatically.
+---
+ plugins/policy.c | 39 +++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 39 insertions(+)
+
+diff --git a/plugins/policy.c b/plugins/policy.c
+index 1f5a506a2..de51e58b9 100644
+--- a/plugins/policy.c
++++ b/plugins/policy.c
+@@ -297,6 +297,42 @@ static void sink_cb(struct btd_service *service, btd_service_state_t old_state,
+       }
+ }
++static void hs_cb(struct btd_service *service, btd_service_state_t old_state,
++                                              btd_service_state_t new_state)
++{
++      struct btd_device *dev = btd_service_get_device(service);
++      struct policy_data *data;
++      struct btd_service *sink;
++
++      /* If the device supports Sink set a timer to connect it as well */
++      sink = btd_device_get_service(dev, A2DP_SINK_UUID);
++      if (sink == NULL)
++              return;
++
++      data = policy_get_data(dev);
++
++      switch (new_state) {
++      case BTD_SERVICE_STATE_UNAVAILABLE:
++              break;
++      case BTD_SERVICE_STATE_DISCONNECTED:
++              break;
++      case BTD_SERVICE_STATE_CONNECTING:
++              break;
++      case BTD_SERVICE_STATE_CONNECTED:
++              /* Check if service initiate the connection then proceed
++               * immediately otherwise set timer
++               */
++              if (old_state == BTD_SERVICE_STATE_CONNECTING)
++                      policy_connect(data, sink);
++              else if (btd_service_get_state(sink) !=
++                                              BTD_SERVICE_STATE_CONNECTED)
++                      policy_set_sink_timer(data);
++              break;
++      case BTD_SERVICE_STATE_DISCONNECTING:
++              break;
++      }
++}
++
+ static gboolean policy_connect_tg(gpointer user_data)
+ {
+       struct policy_data *data = user_data;
+@@ -615,6 +651,9 @@ static void service_cb(struct btd_service *service,
+               controller_cb(service, old_state, new_state);
+       else if (g_str_equal(profile->remote_uuid, AVRCP_TARGET_UUID))
+               target_cb(service, old_state, new_state);
++      else if (g_str_equal(profile->remote_uuid, HFP_HS_UUID) ||
++                      g_str_equal(profile->remote_uuid, HSP_HS_UUID))
++              hs_cb(service, old_state, new_state);
+       /*
+        * Return if the reconnection feature is not enabled (all
+-- 
+cgit 1.2-0.3.lf.el7
+
diff --git a/net-wireless/bluez/files/bluez-udevadm-path-r1.patch b/net-wireless/bluez/files/bluez-udevadm-path-r1.patch
new file mode 100644 (file)
index 0000000..ac1c94c
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/tools/hid2hci.rules
++++ b/tools/hid2hci.rules
+@@ -20,6 +20,7 @@
+ # Unfortunately the only event seen is the BT device disappearing, so the mouse
+ # device needs to be chased down on the USB bus.
+ ATTR{bDeviceClass}=="e0", ATTR{bDeviceSubClass}=="01", ATTR{bDeviceProtocol}=="01", ATTR{idVendor}=="413c", \
++  ENV{REMOVE_CMD}="/bin/udevadm trigger --action=change --subsystem-match=usb --property-match=HID2HCI_SWITCH=1"     \
+   ENV{REMOVE_CMD}="/sbin/udevadm trigger --action=change --subsystem-match=usb --property-match=HID2HCI_SWITCH=1"
+ # CSR devices
index 3f1b1fdf5cd37862483651f46ae129a6805799b9..31e86951f85c4a4e01ca4d34ceda97b9a612ee8a 100644 (file)
     purpose by default. All this tools shouldn't be used. Then, please
     notify upstream about you still need them to let them know the
     situation.</flag>
-  <flag name="mesh">Add support for Bluetooth Mesh control application and advertising
-    bearer.</flag>
-  <flag name="obex">Enable OBEX transfer support.</flag>
-  <flag name="test-programs">Install tools for testing of
-    various Bluetooth functions</flag>
+  <flag name="mesh">Add support for Bluetooth Mesh control application and advertising bearer.</flag>
+  <flag name="midi">Enable MIDI support</flag>
+  <flag name="obex">Enable OBEX transfer support</flag>
+  <flag name="test-programs">Install tools for testing of various Bluetooth functions</flag>
   <flag name="user-session">Allow compatibility with user-session semantics for session bus under systemd</flag>
 </use>
 <upstream>