turn down default video mode to avoid problems on smaller screens (bug #327965) with...
authorMichael Sterrett <mr_bones_@gentoo.org>
Sat, 15 Oct 2011 20:14:04 +0000 (20:14 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Sat, 15 Oct 2011 20:14:04 +0000 (20:14 +0000)
Package-Manager: portage-2.1.10.11/cvs/Linux i686

games-simulation/gl117/ChangeLog
games-simulation/gl117/Manifest
games-simulation/gl117/files/gl117-1.3.2-mode.patch [new file with mode: 0644]
games-simulation/gl117/gl117-1.3.2.ebuild

index e024e3a2d3e764bb426b05cc2734f75741382577..9079d1aea12c35197ecfd3e8fb8df34e766ea645 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for games-simulation/gl117
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.22 2010/09/16 16:59:34 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.23 2011/10/15 20:14:04 mr_bones_ Exp $
+
+  15 Oct 2011; Michael Sterrett <mr_bones_@gentoo.org> gl117-1.3.2.ebuild,
+  +files/gl117-1.3.2-mode.patch:
+  turn down default video mode to avoid problems on smaller screens (bug
+  #327965) with patch from Nick White
 
   16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> gl117-1.3.2.ebuild:
   virtual/glut -> media-libs/glut
index 5400904c93a9defd1086e13d9d6bd24e68d19b9e..9f08f3a85fb7bf1239d75f27521d4bbf165d264a 100644 (file)
@@ -1,4 +1,5 @@
+AUX gl117-1.3.2-mode.patch 395 RMD160 7d1460c52263aef00fabee1209790dff9a4bb412 SHA1 46b3954dac2997b5f1cd1673d18272acbd5b4c5b SHA256 2d5f184bc295a79ef49ef617f3110552a564ed2a9e1575a216ab4aed81cd5075
 DIST gl-117-1.3.2-src.tar.bz2 2411075 RMD160 a2996d59663cff3ba478294a71bafa8974023d30 SHA1 9782e1438fab9e992c20092a48cc50b01bc72f34 SHA256 64bd0190a102725c76eba4983a5d79a0979ec42a087c56c8025b461f6e0e6ffb
-EBUILD gl117-1.3.2.ebuild 901 RMD160 995a1c33e7aaa6d1a70083a9eb75ccd0a3d28089 SHA1 cf0b2571ac0f485c3320b8372b1af4c8e2636260 SHA256 dd688555695383f8400d6692c41994767125f04bb832f64abe09bb14c41a5009
-MISC ChangeLog 2765 RMD160 388a11f64324b881f3ca95cdf4d2fee3a7b3b2a4 SHA1 f4c170d41fc343ad812873545a3a75de6d0afb20 SHA256 bd9c460e6948a0072d999ef24f3fdbb584d9fd0f6b060a0c3aa9de1919f00809
+EBUILD gl117-1.3.2.ebuild 962 RMD160 78fadb798dedd316daa643bfac3934fe1c0f9d25 SHA1 c2941f5880afb2f0db254cff08adfee6cec21e37 SHA256 249e0b88236d325bfd9d4dd80829a3172f2747697f2194980692b20d00e08d0c
+MISC ChangeLog 2985 RMD160 7df06ba3be66dec55e66b8228e09bf7ce2eb9858 SHA1 b9bb7f549f574a324aa15e4c03244d40301b248d SHA256 25a565a90672e88a7240f84c57661b60f7faac0232a41657e100f5c8fb704f37
 MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
new file mode 100644 (file)
index 0000000..c74e07c
--- /dev/null
@@ -0,0 +1,12 @@
+--- src/main.cpp.orig  2010-07-13 09:35:18.374122609 +0100
++++ src/main.cpp       2010-07-13 09:35:45.334955120 +0100
+@@ -71,8 +71,7 @@ int mode = 0;
+ // pre-defined screen resolutions (x, y, bpp, fullscreen)
+ int resolution [4] [4] =
+-        { { 1024, 768, 32, 1 },
+-          { 800, 600, 32, 1 },
++        { { 800, 600, 32, 1 },
+           { 640, 480, 32, 1 },
+           { 640, 480, 32, 0 } };
index 8138b68284f46c9bcb3e1066af9b79dc4217d147..a85a2a8c43e75b62fbda841f70dc068953dcfe09 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/gl117-1.3.2.ebuild,v 1.10 2010/09/16 16:59:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/gl117-1.3.2.ebuild,v 1.11 2011/10/15 20:14:04 mr_bones_ Exp $
 
 EAPI=2
 inherit eutils games
 
 MY_P="gl-117-${PV}-src"
 DESCRIPTION="An action flight simulator"
-HOMEPAGE="http://www.heptargon.de/"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
 SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
 
 LICENSE="GPL-2"
@@ -23,6 +23,8 @@ DEPEND="media-libs/libsdl[audio,joystick,opengl,video]
 
 S=${WORKDIR}/${MY_P}
 
+PATCHES=( "${FILESDIR}"/${P}-mode.patch )
+
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
        newicon doc/src/falcon.jpg ${PN}.jpg