dev-python/sphinxcontrib-blockdiag: Bump to 2.0.0
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Dec 2019 07:35:54 +0000 (08:35 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Dec 2019 08:39:37 +0000 (09:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-blockdiag/Manifest
dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild [new file with mode: 0644]

index 46691b0b443f5ab7a7bfab57ff4c9c97d0650c85..d23cdbdcf6513524a8447054b5890021ae94b10d 100644 (file)
@@ -1 +1,2 @@
 DIST sphinxcontrib-blockdiag-1.5.5.tar.gz 12066 BLAKE2B 4913aa53b365a05db2962c81c3f15df748c3424c88dc70bb5c97325c92492852698246b2d644748fde46ccc9ac6535871036851798db6d9db5e9610c5ef58b45 SHA512 4c007e2c394bf90ff84a000cf44ec1d50b39286a32929c89a64320299a70f10e44da35d942e7bb8697a9d61eb6a551f74bd15349cf0b439369aaaf12d175635a
+DIST sphinxcontrib-blockdiag-2.0.0.tar.gz 11903 BLAKE2B 9301fe05ff936836e8e648a507b7e2e5fd8cada58252fd46b274a4bb3e6b51b00b7696ceee712d12bd590c40c5ae1235e0b532ef55ffc2e78b2986cdae64a0f2 SHA512 305ad9b27bbb44480c69139cc0ae9cd8e47c6ad95da5b14a964c703a17e62ab9b342ff567e8312e403549a794f6381fe4c4d444ccb7a8e41410d1a3754ffb3f1
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..89d49e8
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+       >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+       >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/reportlab[${PYTHON_USEDEP}]
+               dev-python/sphinx-testing[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests nose
+
+RDEPEND+="
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i -e /build-base/d setup.cfg || die
+       # Those tests are known-broken upstream
+       # https://github.com/blockdiag/sphinxcontrib-blockdiag/pull/11
+       rm tests/test_latex.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}