sci-libs/qfits: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:32 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:32 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-libs/qfits/files/qfits-6.2.0-open.patch
sci-libs/qfits/files/qfits-6.2.0-ttest.patch
sci-libs/qfits/qfits-6.2.0.ebuild

index 71d2df1a692a803f2ef98460c72e58df3277eda1..951970da6dc4884bd394a4684d1c2e1c56faf0b3 100644 (file)
@@ -1,6 +1,5 @@
-diff -ur qfits-6.2.0/src/qfits_memory.c qfits-6.2.0.new/src/qfits_memory.c
---- qfits-6.2.0/src/qfits_memory.c     2006-08-24 17:01:56.000000000 +0200
-+++ qfits-6.2.0.new/src/qfits_memory.c 2007-09-21 13:43:19.000000000 +0200
+--- a/src/qfits_memory.c
++++ b/src/qfits_memory.c
 @@ -308,7 +308,7 @@
          /* Create swap file with rights: rw-rw-rw- */
          swapfileid = ++ qfits_memory_table.file_reg ;
index ee87bfc702ca1aa28e3455cbd250f535ee98dcf2..a333a32e0a68a7577229cc5aa09bdb2e6133799c 100644 (file)
@@ -1,5 +1,5 @@
---- test/test_tfits.c  2006-04-27 14:08:43.000000000 +0100
-+++ test/test_tfits.c.new      2007-02-23 00:29:41.000000000 +0000
+--- a/test/test_tfits.c
++++ b/test/test_tfits.c
 @@ -322,7 +322,7 @@
       *    Test on BINARY tables
       */
index e98cd4afcfa29868126832f759ba4f0dcf8253ac..181c4777ba8a2a2122151911d3bc59050191501b 100644 (file)
@@ -1,23 +1,27 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
 
 DESCRIPTION="ESO stand-alone C library offering easy access to FITS files"
 HOMEPAGE="http://www.eso.org/projects/aot/qfits/"
 SRC_URI="ftp://ftp.hq.eso.org/pub/${PN}/${P}.tar.gz"
+
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-DEPEND=""
-RDEPEND=""
+IUSE="doc"
 
 PATCHES=( "${FILESDIR}"/${P}-{ttest,open}.patch )
 
+src_configure() {
+       econf --disable-static
+}
+
 src_install() {
-       autotools-utils_src_install
-       use doc && dohtml html/*
+       use doc && HTML_DOCS=( html/. )
+       default
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }