sci-geosciences/opencpn-plugin-climatology: added new snapshot version
authorMarc Schiffbauer <mschiff@gentoo.org>
Fri, 16 Mar 2018 22:55:41 +0000 (23:55 +0100)
committerMarc Schiffbauer <mschiff@gentoo.org>
Fri, 16 Mar 2018 23:46:00 +0000 (00:46 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sci-geosciences/opencpn-plugin-climatology/Manifest
sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-1.0.20180316.ebuild [new file with mode: 0644]

index 9e025b7e1a0865e91be32e64c9c15f71af877d73..faa48c57c17f449e634b2f2688e24572db63e1e7 100644 (file)
@@ -1,2 +1,3 @@
 DIST opencpn-plugin-climatology-1.0-CL-DATA.tar.xz 5830716 BLAKE2B 57e781f4d86ec17456e786629ec5b82c9aba872c2f8c26ec628e4ab5314b0a3c6933cc0c7a36616830038add1f95a52b8acd7c6f03cb702c611be255a3b91f1a SHA512 5c0b724e7acbfe4a7f494d107806a3491f000f26f4a92519294975dd57a0ba68919c4bed3571ec8fa652138f26f09abd3742a1e5097fa54714564c70f84fbfd3
+DIST opencpn-plugin-climatology-1.0.20180316.tar.gz 428431 BLAKE2B ec6c2493c23eab5d08a2fc1490ea1ab112eb55743d767f7b667a8752d965269cc920459bc63458942912381400af94dc94244ce744aaf83fe4a46c0c3bc3d505 SHA512 cb65916c743729b1d51b1f39aeb62f55f4260a98117234671abeaddb8f9789e1166adc838259efb9da3002ed3143440b4a236f6d14837e0fc709472ed8c9fe3f
 DIST opencpn-plugin-climatology-1.0.tar.gz 298279 BLAKE2B beca26e2f6af956f4e834e23329f5e44cbeaa7202c03f72043af2d379946b0b6c061f866723666661fcdb15ea43eda2eebf308bdee3048386daba9ea7bae41c2 SHA512 6ace4fd2fb1625cbbff9305ca0b25fc275ed4b153473786b8f70cf31451f17010d0c59ec59dd22c2eed49833bf1d1785945e752b59169ecd89434ed049a33baf
diff --git a/sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-1.0.20180316.ebuild b/sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-1.0.20180316.ebuild
new file mode 100644 (file)
index 0000000..0f1404e
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="climatology_pi"
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+       inherit git-r3 cmake-utils wxwidgets
+       KEYWORDS=""
+else
+       SRC_URI="
+               https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       "
+       inherit cmake-utils wxwidgets
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+SRC_URI="
+       $SRC_URI
+       mirror://sourceforge/opencpnplugins/climatology_pi/CL-DATA-1.0.tar.xz -> ${PN}-1.0-CL-DATA.tar.xz
+"
+
+DESCRIPTION="Climatology Plugin for OpenCPN (includes CL-DATA)"
+HOMEPAGE="https://github.com/seandepagnier/climatology_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       x11-libs/wxGTK:${WX_GTK_VER}
+       >=sci-geosciences/opencpn-4.2.0
+       sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       need-wxwidgets unicode
+       cmake-utils_src_prepare
+}
+src_install() {
+       cmake-utils_src_install
+       insinto "/usr/share/opencpn/plugins/${MY_PN}/data/"
+       doins "${S}"/{,../}data/*
+}