dev-php/igbinary: revision bump to fix DOCS.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 27 Sep 2015 18:03:01 +0000 (14:03 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 27 Sep 2015 18:03:01 +0000 (14:03 -0400)
The existing DOCS string contained a nonexistent file. It has been
updated with the correct values, and a little cleanup was performed at
the same time.

Package-Manager: portage-2.2.20.1

dev-php/igbinary/Manifest
dev-php/igbinary/igbinary-1.2.1-r1.ebuild [new file with mode: 0644]

index 8a6daf1a64ce326cb78694f2c71ce0f3b11ea393..9995479931814a46f026bd07ff75086986024245 100644 (file)
@@ -1 +1,2 @@
+DIST igbinary-1.2.1-r1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
 DIST igbinary-1.2.1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
diff --git a/dev-php/igbinary/igbinary-1.2.1-r1.ebuild b/dev-php/igbinary/igbinary-1.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..258ea58
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="ChangeLog NEWS README.md"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+       my_conf="--enable-${PN}"
+       php-ext-source-r2_src_configure
+}
+
+src_test() {
+       for slot in $(php_get_slots); do
+               php_init_slot_env ${slot}
+               NO_INTERACTION="yes" emake test \
+                       || die "test suite failed for slot ${slot}"
+       done
+}