sys-devel/clang-common: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:40 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:46 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
sys-devel/clang-common/clang-common-9.0.1.9999.ebuild

index d1ce28354dec61d4f53b0ab6edfabc89c7225cde..6b707e3d41ff831de20bc1586102b61e83fbb40b 100644 (file)
@@ -8,8 +8,8 @@ inherit bash-completion-r1 git-r3
 DESCRIPTION="Common files shared between multiple slots of clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
-       https://github.com/llvm-mirror/clang.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/clang
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -20,7 +20,7 @@ PDEPEND="sys-devel/clang:*"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+       git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
 }
 
 src_configure() { :; }
index cc703baf0c50127eb2167847c298933dcdf785cb..eecb0ff749dccbd35b09198b8c697d782243069a 100644 (file)
@@ -8,9 +8,9 @@ inherit bash-completion-r1 git-r3
 DESCRIPTION="Common files shared between multiple slots of clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
-       https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/clang
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -21,7 +21,7 @@ PDEPEND="sys-devel/clang:*"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+       git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
 }
 
 src_configure() { :; }