app-antivirus/fangfrisch: Enhance post-install message
authorRalph Seichter <github@seichter.de>
Sun, 5 Apr 2020 19:08:31 +0000 (21:08 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 6 Apr 2020 08:08:31 +0000 (11:08 +0300)
The post-install message now displays the exact shell commands that
should be executed after a fresh installation. This saves the user from
having to refer to the official Fangfrisch documentation.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/15238
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-antivirus/fangfrisch/fangfrisch-1.2.0.ebuild

index e00795c2f9d858434e566b97f37db8ef5b3ca5b7..96c6bbfecc5911f7220674101bba39007b9725b4 100644 (file)
@@ -11,18 +11,29 @@ inherit distutils-r1 readme.gentoo-r1
 DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
 HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
 SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
 DISABLE_AUTOFORMATTING=1
-DOC_CONTENTS="Fresh installations:
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
 
-Before enabling /etc/cron.d/${PN} configure Fangfrisch,
-then run the 'initdb' command.
+### Fresh installations:
 
-Updating from release 1.0.1:
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
 
-Either create a fresh database or manually delete all existing
-database tables, then run the 'initdb' command.
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
 
-See https://rseichter.github.io/fangfrisch/ for more information."
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
 
 LICENSE="GPL-3+"
 SLOT="0"