Add Makefile to create distfiles. Update ChangeLog to acknowledge djanderson. Update...
authorfuzzyray <fuzzyray@gentoo.org>
Tue, 5 May 2009 20:24:30 +0000 (20:24 -0000)
committerfuzzyray <fuzzyray@gentoo.org>
Tue, 5 May 2009 20:24:30 +0000 (20:24 -0000)
svn path=/trunk/gentoolkit/; revision=598

ChangeLog
Makefile [new file with mode: 0644]
setup.py

index 65978801a9a3f9d181c806a523c15c990583da25..1116f961d5be5ad58891820ac69f66c300192f76 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2009-05-09: Paul Varner <fuzzyray@gentoo.org>
+       * equery: Added modular rewrite from djanderson
+       * gentoolkit: Added modular rewrite from djanderson
+       * All: converted to setup.py build system
+
 2009-04-30: Paul Varner <fuzzyray@gentoo.org>
        * revdep-rebuild: Add patch from loki_val to check -l dependencies in 
        .la files (Bug #267898)
diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..462bc56
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+# Copyright 2003-2004 Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright 2003-2009 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+# $Header$
+
+all:
+       echo "YARMOUTH (vb.) To shout at foreigners in the belief that the louder you speak, the better they'll understand you." 
+       echo $(VERSION)
+
+clean:
+       rm -rf release
+
+dist: dist-gentoolkit
+
+dist-gentoolkit:
+       mkdir -p release
+       sed -i "s/^VER =.*/VER = '$(VERSION)'/" setup.py
+       python setup.py sdist --dist-dir release
+       svn revert setup.py
+       rm -f MANIFEST
index b94b2df1c6406e5af07750d925e07191bc281071..062475f48ceb0a98f785157a6bf62e0ba617fad2 100755 (executable)
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
 
 from distutils.core import setup
 
-VER = '0.3.0_rc4'
+VER = '9.9.9.9'
 
 setup(
        name='gentoolkit',