dev-python/pytools: Remove pytest-runner dep
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:46:28 +0000 (10:46 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 11:05:41 +0000 (12:05 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytools/pytools-2017.4-r1.ebuild
dev-python/pytools/pytools-9999.ebuild

index d410d12751d568bd53348bb1b9f7cd31c4f11206..fb72f5a4924356a84a94d2d3fa3b4a5dc8538e88 100644 (file)
@@ -29,10 +29,9 @@ DEPEND="
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
        )
 "
 
 python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
+       pytest -vv || die "Tests fail with ${EPYTHON}"
 }
index 5b1dd65f9e1551c9950f3d10edc79de1efbf510b..765b22bf080c47eca29141e5adad095c9805b465 100644 (file)
@@ -29,10 +29,9 @@ DEPEND="
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
        )
 "
 
 python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
+       pytest -vv || die "Tests fail with ${EPYTHON}"
 }