dev-lang/php: Emulate PHP ./buildconf in PHP 7.4
authorBrian Evans <grknight@gentoo.org>
Tue, 17 Sep 2019 17:40:33 +0000 (13:40 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 17 Sep 2019 17:40:33 +0000 (13:40 -0400)
Upstream has changed how macros are defined by the autoconf system
This breaks eautoreconf with latest libtool.
Previously we attempted to copy in new libtool, but this breaks external
extensions.  Instead, do what upstream expects using our own tools
to ensure cross-compliation support.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-lang/php/php-7.4.0_rc1.ebuild

index 4c04d93e4d4ddd67b00fb50a3483c3f576de48ba..fafdcb64e838b28a402ab325a590d87cf00889c4 100644 (file)
@@ -218,9 +218,11 @@ src_prepare() {
                sapi/fpm/php-fpm.conf.in \
                || die 'failed to move the include directory in php-fpm.conf'
 
-       # Bug 669566 - necessary so that build tools are updated for commands like pecl
-       cp "${BROOT}/usr/share/aclocal/libtool.m4" build/ || die
-       eautoreconf
+       # Emulate buildconf to support cross-compilation
+       rm -fr aclocal.m4 autom4te.cache config.cache \
+               configure main/php_config.h.in || die
+       eautoconf --force
+       eautoheader
 }
 
 src_configure() {