dev-ros/tf2_msgs: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 16:27:15 +0000 (18:27 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 17:04:20 +0000 (19:04 +0200)
Package-Manager: portage-2.2.21

dev-ros/tf2_msgs/Manifest [new file with mode: 0644]
dev-ros/tf2_msgs/metadata.xml [new file with mode: 0644]
dev-ros/tf2_msgs/tf2_msgs-0.5.12.ebuild [new file with mode: 0644]
dev-ros/tf2_msgs/tf2_msgs-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/tf2_msgs/Manifest b/dev-ros/tf2_msgs/Manifest
new file mode 100644 (file)
index 0000000..ec008bb
--- /dev/null
@@ -0,0 +1 @@
+DIST geometry_experimental-0.5.12.tar.gz 131234 SHA256 430115ef4a3352e8b00596ff7406e6cb14fc1720250cf164754cf724c7f371c3 SHA512 1a1a33db529d0810661c020552642d914de01a14e5b17b611fb7743a795c47e3f68d480ee4544b4ad86f7b1c947ea8b23cda09535ce046fdc45da1c40fc34711 WHIRLPOOL fd894a43e0110eeab1f085faa32a339a72d922d57ae68ee82c2b54f73c246090f3537483f1ca68147f5b7b7a5c7502f9fd4ab733da150c68af94ea2d87859ab1
diff --git a/dev-ros/tf2_msgs/metadata.xml b/dev-ros/tf2_msgs/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/tf2_msgs/tf2_msgs-0.5.12.ebuild b/dev-ros/tf2_msgs/tf2_msgs-0.5.12.ebuild
new file mode 100644 (file)
index 0000000..b27e93a
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/tf2_msgs/tf2_msgs-9999.ebuild b/dev-ros/tf2_msgs/tf2_msgs-9999.ebuild
new file mode 100644 (file)
index 0000000..b27e93a
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"