dev-db/mysqltuner: version bump to 1.6.18.
authorSergiy Borodych <Sergiy.Borodych@gmail.com>
Mon, 13 Feb 2017 16:44:12 +0000 (18:44 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 16 Mar 2017 23:09:49 +0000 (00:09 +0100)
Gentoo-Bug: https://bugs.gentoo.org/595634
Closes: https://github.com/gentoo/gentoo/pull/3956

dev-db/mysqltuner/Manifest
dev-db/mysqltuner/metadata.xml
dev-db/mysqltuner/mysqltuner-1.6.18.ebuild [new file with mode: 0644]

index 9c3e35fd3dcf46278c76d4b4b3926164bd55a4ce..70850f102e845a83de9011f099066385840e4438 100644 (file)
@@ -1,2 +1,3 @@
 DIST mysqltuner-1.2.0.tar.gz 24562 SHA256 54b743808f7f1d882cc912ffbb62dae57303e3e17f45aefd55a16825c016bc9d SHA512 b38277c31c1a870525f20bc1c023fe9675403834313a65c99c445a5fa1048c7aa3dc8ed5a9a9255c4844bdb001b28ee45be807306d0f1739c170d8ee9e0ab53f WHIRLPOOL 5290f77df91bcb23cc2bbb5097a08df54bc4e32560732ff078005bdd9acdf74a8f76647b893ab600dee4d848a70d6a6923e9806b30fb9504c6d3f5d31067be75
 DIST mysqltuner-1.6.0.tar.gz 53424 SHA256 dc3045b9ffae7837d187d2b1ef4c42648bf7ffc6bb9f69864a4bfeecd5205e37 SHA512 904022ef64eaf75f3294a9a5123dc5e00482d95378722df63140bc6859ec245c32d9b06d19955790a5e29b9335e6da3df2cebdeb4659cb9058561866f6ec69c2 WHIRLPOOL fa1cde57da2eb67ca6524aea6cae58864128ab7beebb9dab779ba6f44b7a38fb1a2b5a6a729f0b0c73e78e8bd61d3519ea0990885e992e00091b178d110cec3a
+DIST mysqltuner-1.6.18.tar.gz 169074 SHA256 ae2b2668198fb78a7685fc4a372bafcef0a91b1dca15d065dae73eeb74bcd6cb SHA512 8067b7ac4a4fe7398ee2cdc463a30042f46972f97680b49912dca46fd1d835989aa4115568dbe5473ff28c4d956bf0ad70537318db788dd56bc93ad220e6bcb6 WHIRLPOOL 0ffe6459f157cc4e7e015dde806f0e5086c546f14c53855b04f61edba3e2e8b4b98a57212d10d48722bb2277041561729b14ec870383df56bd32587fb6275c4b
index 4b9e3adf3168b8c82b9af38d497279eeec2e5898..b5fa8bce6890ee1673207f5dddfb6c7b056ce45b 100644 (file)
@@ -3,6 +3,7 @@
 <pkgmetadata>
   <!-- maintainer-needed -->
   <upstream>
-    <remote-id type="github">rackerhacker/MySQLTuner-perl</remote-id>
+    <remote-id type="github">major/MySQLTuner-perl</remote-id>
+    <bugs-to>https://github.com/major/MySQLTuner-perl/issues</bugs-to>
   </upstream>
 </pkgmetadata>
diff --git a/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild b/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild
new file mode 100644 (file)
index 0000000..7a51ca5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="http://www.mysqltuner.com/"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+       virtual/perl-Getopt-Long
+       virtual/mysql"
+
+DOCS=( README.* USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       newbin "${PN}.pl" "${PN}"
+
+       # The passwords and vulnerabilities are meant to be fed to the script uncompressed
+       docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+       einstalldocs
+}