games-misc/ponysay: Drop old 3.0.2
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 18 Feb 2019 19:32:39 +0000 (19:32 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 18 Feb 2019 19:45:36 +0000 (19:45 +0000)
Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-misc/ponysay/Manifest
games-misc/ponysay/ponysay-3.0.2.ebuild [deleted file]

index 58abce44b799c5c6790a8e1df78c21b5bcb0c0f5..35877ac320b18b61eb7cbd0ec9cd203c55af6d87 100644 (file)
@@ -1,2 +1 @@
-DIST ponysay-3.0.2.tar.gz 2110382 BLAKE2B eb547ca62315c1aff227bec5e71328b1e333ba6aa14061b262d1130997ec2de2d54665fd498c8c571eacce15757030ca84d29d82a40b9fc82675d63e62617118 SHA512 47d5c584b3b8c233567eff534b5109548c92075f69776703bc303929ba4278f67fd599987ef4a098aa871c2af0efd89186f96fa28565e73b4672abeb0c23fa45
 DIST ponysay-3.0.3.tar.gz 2139074 BLAKE2B 3ba477268d68ff9a92bad8028d0b960a2a6152057146368723fea432100a71517c0c343d34b2b1c580fcfa1945bdc273fed276cf4a10c702514e6699cda87a2c SHA512 d6ff905404192bdc207952a4a914458d7f25ddcfcea95763ae277a2a3bc7ab33e86a0a229c1b10ff7295b7a89d6e1b61406feefb6bdf9026f4076d0ed70dbe93
diff --git a/games-misc/ponysay/ponysay-3.0.2.ebuild b/games-misc/ponysay/ponysay-3.0.2.ebuild
deleted file mode 100644 (file)
index f71db68..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-inherit bash-completion-r1 python-single-r1
-
-DESCRIPTION="cowsay reimplemention for ponies"
-HOMEPAGE="https://github.com/erkin/ponysay"
-SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +non-free bash-completion fish-completion zsh-completion"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
-       doc? ( sys-apps/texinfo )"
-
-RDEPEND="${PYTHON_DEPS}
-       fish-completion? ( app-shells/fish )
-       zsh-completion? ( app-shells/zsh )"
-
-setup_py() {
-       "${PYTHON}" setup.py \
-               --prefix="${EPREFIX}"/usr \
-               --everything \
-               --without-info-compression \
-               --without-man-compression \
-               --without-pdf-compression \
-               --without-shared-cache \
-               --freedom=$(usex non-free no yes) \
-               $(use_with fish-completion) \
-               $(use_with zsh-completion) \
-               $(use_with doc info) \
-               $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
-               "${@}" || die
-}
-
-src_compile() {
-       setup_py \
-               $(use_with bash-completion) \
-               build
-}
-
-src_install() {
-       setup_py \
-               --without-bash-completion \
-               --destdir="${D}" \
-               prebuilt
-
-       python_fix_shebang "${ED}"/usr/bin/${PN}
-
-       rm -rv "${ED}"/usr/share/licenses || die
-       dodoc CHANGELOG CONTRIBUTING CREDITS README.md
-
-       use bash-completion &&
-               newbashcomp completion/bash-completion.${PN}.install ${PN}
-}