app-admin/conserver: backport libressl patch to 8.2.3
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 7 Jun 2019 04:35:54 +0000 (21:35 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 7 Jun 2019 04:36:12 +0000 (21:36 -0700)
does not affect openssl users, hence no rebvump

Bug: https://bugs.gentoo.org/687542
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
app-admin/conserver/conserver-8.2.3.ebuild
app-admin/conserver/files/8.2.3-libressl.patch [new file with mode: 0644]

index 9a067d23f7124340d6f1bc413c1c05a3a576e5fe..d9a7265bfbade113bfd57474a62869ffed1ea567 100644 (file)
@@ -32,6 +32,8 @@ RDEPEND="${DEPEND}
 
 DOCS=( CHANGES FAQ PROTOCOL README conserver/Sun-serial contrib/maketestcerts)
 
+PATCHES=( "${FILESDIR}/${PV}-libressl.patch" )
+
 src_prepare() {
        default
        sed -e '/^INSTALL_PROGRAM/s:-s::' \
diff --git a/app-admin/conserver/files/8.2.3-libressl.patch b/app-admin/conserver/files/8.2.3-libressl.patch
new file mode 100644 (file)
index 0000000..8b04acb
--- /dev/null
@@ -0,0 +1,31 @@
+From f4d2a4a30f930c58bf87511f7ed1a982eca66ce3 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Thu, 6 Jun 2019 21:30:16 -0700
+Subject: [PATCH] libressl
+
+backport of https://github.com/conserver/conserver/pull/26
+---
+ conserver/cutil.h | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/conserver/cutil.h b/conserver/cutil.h
+index 63aef65..07aa6d4 100644
+--- a/conserver/cutil.h
++++ b/conserver/cutil.h
+@@ -12,10 +12,12 @@
+ # include <openssl/err.h>
+ # if OPENSSL_VERSION_NUMBER < 0x10100000L
+ #  define TLS_method SSLv23_method
++# endif/* OPENSSL_VERSION_NUMBER < 0x10100000L */
++# if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ #  define CIPHER_SEC0
+ # else
+ #  define CIPHER_SEC0 ":@SECLEVEL=0"
+-# endif /* OPENSSL_VERSION_NUMBER < 0x10100000L */
++# endif/* OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER) */
+ #endif
+ #if HAVE_GSSAPI
+ # include <gssapi/gssapi.h>
+-- 
+2.21.0
+