dev-python/path-py: Disable fragile timing tests
authorMichał Górny <mgorny@gentoo.org>
Sat, 16 May 2020 08:02:56 +0000 (10:02 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 16 May 2020 09:07:44 +0000 (11:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/path-py/path-py-11.5.2.ebuild
dev-python/path-py/path-py-12.0.2-r2.ebuild

index c95f162bf18516633888114d8fac839c45b80384..dd854041c4dd945b33ac2f1dd0982e59b2089903 100644 (file)
@@ -44,6 +44,9 @@ python_prepare_all() {
        sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
                pytest.ini || die
 
+       # fragile test for import time
+       sed -i -e 's:test_import_time:_&:' test_path.py || die
+
        distutils-r1_python_prepare_all
 }
 
index 511276e331dae8c81d25cac5b154b0f7c4e60ae1..caa323eb0ce04ef43b96a5705b5e622174644b0f 100644 (file)
@@ -47,6 +47,9 @@ python_prepare_all() {
        sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
                pytest.ini || die
 
+       # fragile test for import time
+       sed -i -e 's:test_import_time:_&:' test_path.py || die
+
        distutils-r1_python_prepare_all
 }