dev-python/python-neutronclient: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:55:50 +0000 (12:55 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:28 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-neutronclient/Manifest
dev-python/python-neutronclient/python-neutronclient-6.9.0.ebuild [deleted file]

index 44c335f392130ba26aa108541e83a32c9919e8e3..9ee71140f1d9dbbcf826c15a69765ebe5fd756ba 100644 (file)
@@ -1,2 +1 @@
 DIST python-neutronclient-6.12.0.tar.gz 290025 BLAKE2B f863826a531708fda1b9ddb43f8bfd8f66fbba99ce3fe4afc1135d20fe4718dc7f11789c3e75cf52089690ce0286bf5339c9253d1e7e35916befb52ed905448a SHA512 c7e69e263b37aa14b59b08ecc12f13210e1bd6f10cde10d8b4d5b8b9f912d604e23ff41eed684baf09bb6dc278393a55ca87d6e41e0986235cd3366d321dd85f
-DIST python-neutronclient-6.9.0.tar.gz 284879 BLAKE2B 720d26489dae7e50617ec83c266ac1197dc1934a3b8f5e8a0e285227421cf8814d96d57ab30710b63eb92406663aafb29fe8d8d7efa1e1d2e74c116eaac5902c SHA512 89f5a2004c7888f11a1a17f4287ddf6942e083fc3871be4a8590a5bb86ec557584165a75cb6470ea3f19526eea882b0174746b20800211d11d10fea1210df74f
diff --git a/dev-python/python-neutronclient/python-neutronclient-6.9.0.ebuild b/dev-python/python-neutronclient/python-neutronclient-6.9.0.ebuild
deleted file mode 100644 (file)
index a559c56..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Quantum API"
-HOMEPAGE="https://launchpad.net/neutron"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( doc )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
-               >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-       )"
-
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
-       !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
-       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
-       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
-       >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # built in...
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^flake8-import-order/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && "${PYTHON}" setup.py build_sphinx
-}
-
-python_test() {
-       testr init
-       testr run || die "tests failed under python2.7"
-       flake8 neutronclient/tests || die "run by flake8 over tests folder yielded error"
-}
-
-python_install() {
-       distutils-r1_python_install
-       #stupid stupid
-       local SITEDIR="${D%/}$(python_get_sitedir)" || die
-       cd "${SITEDIR}" || die
-       local egg=( python_neutronclient*.egg-info )
-       #[[ -f ${egg[0]} ]] || die "python_quantumclient*.egg-info not found"
-       ln -s "${egg[0]}" "${egg[0]/neutron/quantum}" || die
-       ln -s neutronclient quantumclient || die
-       ln -s neutron quantumclient/quantum || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}