dev-python/importlib_resources: add doc
authorLouis Sautier <sbraz@gentoo.org>
Sat, 13 Jul 2019 00:30:50 +0000 (02:30 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sat, 13 Jul 2019 01:09:20 +0000 (03:09 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/importlib_resources/importlib_resources-1.0.2-r1.ebuild

index 1e8e022c6b572026433f33fefb6187aa0e39497c..5ebc09e8110e7812588546e2525097455d51697d 100644 (file)
@@ -15,13 +15,14 @@ LICENSE="Apache-2.0"
 
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="doc test"
 
 RDEPEND="
        $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
        virtual/python-typing[${PYTHON_USEDEP}]
 "
 BDEPEND="
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( ${RDEPEND} )
        dev-python/setuptools[${PYTHON_USEDEP}]
 "
@@ -29,6 +30,18 @@ BDEPEND="
 # https://gitlab.com/python-devs/importlib_resources/issues/71
 PATCHES=( "${FILESDIR}/${P}-skip-wheel.patch" )
 
+python_prepare_all() {
+       sed -i "/'sphinx.ext.intersphinx'/d" ${PN}/docs/conf.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build ${PN}/docs docs/_build/html || die
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
 python_test() {
        "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
 }