dev-python/fasteners: adding for openstack liberty
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 3 Sep 2015 02:56:24 +0000 (21:56 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 3 Sep 2015 03:41:22 +0000 (22:41 -0500)
dev-python/fasteners/Manifest [new file with mode: 0644]
dev-python/fasteners/fasteners-0.13.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/fasteners/Manifest b/dev-python/fasteners/Manifest
new file mode 100644 (file)
index 0000000..5aa7a5c
--- /dev/null
@@ -0,0 +1 @@
+DIST fasteners-0.13.0.tar.gz 17510 SHA256 76a804e7d5793ea5239aee7ccface4a51262fdd1d49cdb407838c2f8076ef059 SHA512 921affd29452548e97e0dbb2dc70d7f0df9c181b6f17da734dceef37f42f0873d4316da50905b56d9dae20801001d1fdde94569f6bb41f60fc211ef5bc7f161d WHIRLPOOL 3b94d7700a7e600328a42ddac0b3e2306a79dd2bd4fb1b3e540d0d635da3a81e75339abdf612833fbaf717e36430539dbf2a1b73390b0f8e57b665ac1e65f866
diff --git a/dev-python/fasteners/fasteners-0.13.0.ebuild b/dev-python/fasteners/fasteners-0.13.0.ebuild
new file mode 100644 (file)
index 0000000..392de51
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]"