gnome-base/gsettings-desktop-schemas: bump to 3.34.0
authorMart Raudsepp <leio@gentoo.org>
Tue, 25 Feb 2020 08:47:36 +0000 (10:47 +0200)
committerMart Raudsepp <leio@gentoo.org>
Wed, 26 Feb 2020 08:29:40 +0000 (10:29 +0200)
This only adds new gschema keys for GNOME 3.34 functionalities, no
incompatibilities with 3.32 can be there in any way.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/gsettings-desktop-schemas/Manifest
gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.34.0.ebuild [new file with mode: 0644]

index c5dc7eac7e6da989224314c22b15aee64e3c8fc4..9d3663a0373a2c87f2e75cc7ebcd37383f3edc2f 100644 (file)
@@ -1,2 +1,3 @@
 DIST gsettings-desktop-schemas-3.24.1.tar.xz 638780 BLAKE2B c1857636e18c69658458aa9dfd65a7c3983791000f16eba08f706c243a0b804ed20dfde58f9cbe879f41348dc8257ecab86d5111c89bc1aacca1d8b62f2c0332 SHA512 c3970d61cc1c29bf97a39c439b3e0ba5c5d5c0f811e17b8884f106f095b159dd0c43cb90e02561edcc26e15b2b887e960d38de1c0e7498413db0c63102f15833
 DIST gsettings-desktop-schemas-3.32.0.tar.xz 628888 BLAKE2B 7d675597d861ee8ee8258f037d06d6f728e9705c7e121508a811bbad000b1ef10a7e2ef23066cec01c34865648f4f0a204716306643db1a4cbd505801ce939c1 SHA512 cf1d78a8f9f1697e20c995286b50d556c2ecc83bf4b28be19b3258a724494a2827fb9567cabf29cda1c590488fd2645e905072e08321766c8bdddd22ac3710dc
+DIST gsettings-desktop-schemas-3.34.0.tar.xz 650468 BLAKE2B a275cd011c255531b293ccb875159ea4465c79852a3d1be2a03faafa8dbb6ba7137d72c7a59bce93b6ce5f187ebf92aca334dc3c51c8de5ee3af3092fc250fe5 SHA512 6cbe59facf77566ed93faabafc6b00ad03fb398a9a4686ba94a08b1c2d0df1d44bd673fb4d51340209a66ebc0aa32095615e7e63b78f4cc4c10d240a7b0a8fa1
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.34.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.34.0.ebuild
new file mode 100644 (file)
index 0000000..bd590c7
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="!<gnome-base/gdm-3.8"
+RDEPEND="${DEPEND}"
+BDEPEND="
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+       "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_configure() {
+       meson_src_configure $(meson_use introspection)
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}