app-shells/tcsh: Bump to EAPI=5 and use subslot deps for ncurses
authorJustin Lecher <jlec@gentoo.org>
Thu, 20 Aug 2015 11:51:56 +0000 (13:51 +0200)
committerJustin Lecher <jlec@gentoo.org>
Thu, 20 Aug 2015 12:22:58 +0000 (14:22 +0200)
* drop die from econf

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-shells/tcsh/tcsh-6.17-r1.ebuild
app-shells/tcsh/tcsh-6.17.06.ebuild
app-shells/tcsh/tcsh-6.18.01-r2.ebuild
app-shells/tcsh/tcsh-6.18.01-r3.ebuild
app-shells/tcsh/tcsh-6.18.01-r4.ebuild [new file with mode: 0644]
app-shells/tcsh/tcsh-6.18.01.ebuild

index cb515e8503eb262a8641c6ba6f1ee3be0a896d22..64ec5fe0e9dd3cbf52a31897b34704ae7955a323 100644 (file)
@@ -70,8 +70,7 @@ src_configure() {
 
        econf \
                --prefix="${EPREFIX:-/}" \
-               --datarootdir='${prefix}/usr/share' \
-               || die
+               --datarootdir='${prefix}/usr/share'
 }
 
 src_install() {
index f0378a86b0763e1310d19248550ba9ce4084a49a..34886ee2dbceb128ffe4e5ef374627f63059d767 100644 (file)
@@ -66,8 +66,7 @@ src_configure() {
        econf \
                --prefix="${EPREFIX:-/}" \
                --datarootdir='${prefix}/usr/share' \
-               $(use_enable nls) \
-               || die
+               $(use_enable nls)
 }
 
 src_install() {
index 3dc6ead2c59b07e91c27c820981c07817f3223e4..8fc7f32a3426dd0a50733525b413352caed65566 100644 (file)
@@ -76,8 +76,7 @@ src_configure() {
        econf \
                --prefix="${EPREFIX:-/}" \
                --datarootdir='${prefix}/usr/share' \
-               $(use_enable nls) \
-               || die
+               $(use_enable nls)
 }
 
 src_install() {
index 31db28723a08eaaf7b9cadb5da50d87504b2081e..791d7c1da6d26e47788ffdeb91ee3a975e333b7d 100644 (file)
@@ -77,8 +77,7 @@ src_configure() {
        econf \
                --prefix="${EPREFIX:-/}" \
                --datarootdir='${prefix}/usr/share' \
-               $(use_enable nls) \
-               || die
+               $(use_enable nls)
 }
 
 src_install() {
diff --git a/app-shells/tcsh/tcsh-6.18.01-r4.ebuild b/app-shells/tcsh/tcsh-6.18.01-r4.ebuild
new file mode 100644 (file)
index 0000000..42d2ba1
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools prefix
+
+CONFVER="1.9"
+
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="
+       ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
+       http://www.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls doc"
+RESTRICT="test"
+
+# we need gettext because we run autoconf (AM_ICONV)
+RDEPEND="
+       >=sys-libs/ncurses-5.1:5=
+       virtual/libiconv"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       doc? ( dev-lang/perl )"
+
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-6.14.00-debian-dircolors.patch # bug #120792
+       "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+       "${FILESDIR}"/${PN}-6.14-use-ncurses.patch
+       "${FILESDIR}"/${PN}-6.18.01-aix.patch
+       "${FILESDIR}"/${PN}-6.18.01-gcc5.patch
+)
+
+src_prepare() {
+       epatch "${PATCHES[@]}"
+
+       # fix dependency on ncurses[tinfo], #459484
+       sed \
+               -e "s:\(ncurses\):\1 tinfo:g" \
+               -i configure.in || die
+
+       eautoreconf
+
+       # fix gencat usage
+       sed \
+               -e 's/cat \$\^ \$> | \$(GENCAT) \$@/rm -f $@; $(GENCAT) $@ $> $^/' \
+               -i nls/Makefile.in || die
+
+       # use sysmalloc (for larger alloc sets) on Darwin also
+       sed -i -e 's/__MACHTEN__/__MACH__/' config_f.h || die
+
+       # unify ECHO behaviour
+       echo "#undef ECHO_STYLE" >> config_f.h
+       echo "#define ECHO_STYLE      BOTH_ECHO" >> config_f.h
+
+       eprefixify "${CONFDIR}"/*
+       # activate the right default PATH
+       if [[ -z ${EPREFIX} ]] ; then
+               sed -i \
+                       -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+                       "${CONFDIR}"/csh.login || die
+       else
+               sed -i \
+                       -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+                       "${CONFDIR}"/csh.login || die
+       fi
+}
+
+src_configure() {
+       # make tcsh look and live along the lines of the prefix
+       append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+       append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+       append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+       append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+       append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+       econf \
+               --prefix="${EPREFIX:-/}" \
+               --datarootdir='${prefix}/usr/share' \
+               $(use_enable nls)
+}
+
+src_install() {
+       emake DESTDIR="${D}" install install.man
+
+       DOCS=( FAQ Fixes NewThings Ported README WishList Y2K )
+       if use doc ; then
+               perl tcsh.man2html tcsh.man || die
+               HTML_DOCS=( tcsh.html/*.html )
+       fi
+       einstalldocs
+
+       insinto /etc
+       doins \
+               "${CONFDIR}"/csh.cshrc \
+               "${CONFDIR}"/csh.login
+
+       # bug #119703: add csh -> tcsh symlink
+       dosym /bin/tcsh /bin/csh
+}
index 8e010a492dad5c37eb275bf07267c31cce4f9050..f08276c59b260fe92a80444d904814933758e157 100644 (file)
@@ -66,8 +66,7 @@ src_configure() {
        econf \
                --prefix="${EPREFIX:-/}" \
                --datarootdir='${prefix}/usr/share' \
-               $(use_enable nls) \
-               || die
+               $(use_enable nls)
 }
 
 src_install() {