dev-haskell/edisonapi: new package, a depend of sci-mathematics/agda-2.5.2
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 22:03:07 +0000 (22:03 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:20 +0000 (10:21 +0000)
A library of efficient, purely-functional data structures (API)

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/edisonapi/Manifest [new file with mode: 0644]
dev-haskell/edisonapi/edisonapi-1.3.1.ebuild [new file with mode: 0644]
dev-haskell/edisonapi/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/edisonapi/Manifest b/dev-haskell/edisonapi/Manifest
new file mode 100644 (file)
index 0000000..0a901b6
--- /dev/null
@@ -0,0 +1 @@
+DIST EdisonAPI-1.3.1.tar.gz 30512 SHA256 95a3b8d01599520a50456219b5a2e9f7832bcddaaeb8e94ce777bd87a4a6b56e SHA512 677161da64856421c834856ee2f5ef7f59880883433d5c5c4061f0ab2faa0cb39c4eb83061820b77dab852acc4cce5dc75740fe454b15dbc2e67e6e84510ce42 WHIRLPOOL f664631ce3d58fbc66c33b459291d3827f87f56a564c8dd1608487ee97bfc663ce566ad43776f4bf4aa40d04d2e6c2fe7aec7a6b5be9b9b33ccc496c54d0980d
diff --git a/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild b/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..c07857f
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="EdisonAPI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library of efficient, purely-functional data structures (API)"
+HOMEPAGE="http://rwd.rdockins.name/edison/home/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.0:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/edisonapi/metadata.xml b/dev-haskell/edisonapi/metadata.xml
new file mode 100644 (file)
index 0000000..dac5f3d
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               Edison is a library of purely functional data structures written by
+               Chris Okasaki.  It is named after Thomas Alva Edison and for the
+               mnemonic value EDiSon (Efficent Data Structures).
+               Edison provides several families of abstractions, each with
+               multiple implementations.  The main abstractions provided by Edison are:
+               Sequences such as stacks, queues, and dequeues;
+               Collections such as sets, bags and heaps; and
+               Associative Collections such as finite maps and priority queues
+               where the priority and element are distinct.
+       </longdescription>
+</pkgmetadata>