gui-apps/wl-clipboard: 2.0.0_beta1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 16 Sep 2019 16:45:25 +0000 (11:45 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 16 Sep 2019 16:45:52 +0000 (11:45 -0500)
Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
gui-apps/wl-clipboard/Manifest
gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta1.ebuild [new file with mode: 0644]

index 3c882e36cd2f8196943bedea9e729ac6f11f3ad1..97f8b56fffcbea2ee601ec949798dcce324ce26e 100644 (file)
@@ -1 +1,2 @@
 DIST wl-clipboard-1.0.0.tar.gz 25442 BLAKE2B 02e2e99287e1376f26f73a546654e66ddb9d0a85caf457e4a023f0a02cb4d7a9cb3c8ab5840982bf014afb9fc3601722dd4c2fc4239b74a05d309a0a16d20299 SHA512 328c18a9eb2ccfc788e7ab785077ab8d663c75f2ce8f6f434799575fc76ccc89238faf930948bced216d22bee0adfc810af5e84ffc63bc82c4e1d02da4286296
+DIST wl-clipboard-2.0.0_beta1.tar.gz 39963 BLAKE2B d8c624fd395bbb7d233c9b5b0c3f4ddf369288712498625caaad427616ff190fb3512cccfc4b4506835e6bf9dc432a272fc6696058ec31a1b3355b1a06b5e76a SHA512 d11a89f8a8996f0aba9eb30ddd87715f65390459baccc9f20cb04864c1fdd54f8efe5b10a1eb470efa2b72be871e27fd5fe72df3a61c0b53e5ff41dc111b82ca
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta1.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta1.ebuild
new file mode 100644 (file)
index 0000000..49a5656
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+       SRC_URI="https://github.com/bugaevc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""