dev-python/ipy: Remove old
authorDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 22:12:41 +0000 (23:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 22:12:41 +0000 (23:12 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/ipy/Manifest
dev-python/ipy/ipy-0.83.ebuild [deleted file]

index 547715a7c126942d02a815765f2bbe1175ddfac4..d6c42806e7cdef0f60185f17c6ca3ac3fe125ea4 100644 (file)
@@ -1,2 +1 @@
-DIST IPy-0.83.tar.gz 31816 BLAKE2B 89ca11d292ff3ed6f633aacc2c689e710c5ed43ada32e75425f653bfe87bcf6eb777d5ede33133362833099e51b2248f5e846bae82b28a6050500f25679ddbfb SHA512 6bd69d96fa77dc4ceaf119b81c19a524b871badb37665a763a055e1c8b2ce3433c6e9534f03aa64d02e559dca2fac2c4e1d09b7fd78ed79c0fded88f803ad2de
 DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
diff --git a/dev-python/ipy/ipy-0.83.ebuild b/dev-python/ipy/ipy-0.83.ebuild
deleted file mode 100644 (file)
index 7ac7cac..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/haypo/python-ipy/wiki https://pypi.org/project/IPy/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="examples"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
-       # 1 test fail under pypy, persistent from 0.82a, not a regression.
-       cp -r test_doc.py README test "${BUILD_DIR}" || die
-       pushd "${BUILD_DIR}" > /dev/null || die
-       "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
-       "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
-       popd > /dev/null || die
-}
-
-python_install_all() {
-       use examples && local EXAMPLES=( example/. )
-       distutils-r1_python_install_all
-}