games-strategy/0ad: revbump to fix missing python DEPEND
authorJulian Ospald <hasufell@gentoo.org>
Tue, 15 Sep 2015 23:55:18 +0000 (01:55 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 15 Sep 2015 23:55:46 +0000 (01:55 +0200)
Gentoo-Bug: 560542

games-strategy/0ad/0ad-0.0.18_alpha-r2.ebuild [moved from games-strategy/0ad/0ad-0.0.18_alpha-r1.ebuild with 94% similarity]

similarity index 94%
rename from games-strategy/0ad/0ad-0.0.18_alpha-r1.ebuild
rename to games-strategy/0ad/0ad-0.0.18_alpha-r2.ebuild
index 06c8f8a4fd8220ad3e6a6b1bff08c882e9008c4e..e9c57bd4d1640420a4eec2e3eb157bde8db9119b 100644 (file)
@@ -6,7 +6,10 @@ EAPI=5
 
 WX_GTK_VER="2.8"
 
-inherit eutils wxwidgets toolchain-funcs gnome2-utils games
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,ssl"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils python-any-r1 games
 
 MY_P=0ad-${PV/_/-}
 DESCRIPTION="A free, real-time strategy game"
@@ -41,11 +44,17 @@ RDEPEND="
        sound? ( media-libs/libvorbis
                media-libs/openal )"
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        virtual/pkgconfig
        test? ( dev-lang/perl )"
 
 S=${WORKDIR}/${MY_P}
 
+pkg_setup() {
+       games_pkg_setup
+       python-any-r1_pkg_setup
+}
+
 src_prepare() {
        epatch "${FILESDIR}"/${P}-gentoo.patch
 }