app-arch/xar: base eclass cleanup and add libressl support
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 15 Dec 2015 20:38:34 +0000 (15:38 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 15 Dec 2015 20:38:51 +0000 (15:38 -0500)
Package-Manager: portage-2.2.24

app-arch/xar/xar-1.5.2-r2.ebuild [new file with mode: 0644]

diff --git a/app-arch/xar/xar-1.5.2-r2.ebuild b/app-arch/xar/xar-1.5.2-r2.ebuild
new file mode 100644 (file)
index 0000000..b753675
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://code.google.com/p/xar"
+SRC_URI="https://xar.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="acl +bzip2 libressl"
+
+DEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       dev-libs/libxml2
+       sys-libs/zlib
+       acl? ( sys-apps/acl )
+       bzip2? ( app-arch/bzip2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( TODO )
+
+src_prepare() {
+       epatch "${FILESDIR}/${P}-automagic_acl_and_bzip2.patch"
+       epatch "${FILESDIR}/${P}-respect_ldflags.patch"
+       epatch_user
+       eautoconf
+}
+
+src_configure() {
+       econf $(use_enable acl) $(use_enable bzip2)
+}