projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6025336
)
dev-python/pytest: Backport test fixes to 4.6.9
author
Michał Górny
<mgorny@gentoo.org>
Wed, 13 May 2020 08:34:36 +0000
(10:34 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Wed, 13 May 2020 09:03:00 +0000
(11:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest/pytest-4.6.9.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/pytest/pytest-4.6.9.ebuild
b/dev-python/pytest/pytest-4.6.9.ebuild
index 620cc642d5876bae762a4dbf02f8df2242a799b9..b0edb8058feae5057892f13f222e7556791993f3 100644
(file)
--- a/
dev-python/pytest/pytest-4.6.9.ebuild
+++ b/
dev-python/pytest/pytest-4.6.9.ebuild
@@
-52,6
+52,9
@@
DEPEND="
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
!!dev-python/flaky
+ !!dev-python/pytest-aiohttp
+ !!dev-python/pytest-asyncio
+ !!dev-python/pytest-django
)"
PATCHES=(
@@
-69,6
+72,8
@@
python_prepare_all() {
}
python_test() {
+ distutils_install_for_testing
+
# In v4.1.1, pytest started being picky about its own verbosity options.
# running pytest on itself with -vv made 3 tests fail. This is why we don't
# have it below.